summaryrefslogtreecommitdiff
path: root/python-pydocx.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pydocx.spec')
-rw-r--r--python-pydocx.spec192
1 files changed, 192 insertions, 0 deletions
diff --git a/python-pydocx.spec b/python-pydocx.spec
new file mode 100644
index 0000000..e1cbbe4
--- /dev/null
+++ b/python-pydocx.spec
@@ -0,0 +1,192 @@
+%global _empty_manifest_terminate_build 0
+Name: python-PyDocX
+Version: 0.9.10
+Release: 1
+Summary: docx (OOXML) to html converter
+License: BSD
+URL: http://github.com/CenterForOpenScience/pydocx
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2b/c2/015516924e2f671d18371296a62cd0a50842a24eab59844f6c474e9f12e9/PyDocX-0.9.10.tar.gz
+BuildArch: noarch
+
+
+%description
+######
+PyDocX
+######
+
+.. image:: https://travis-ci.org/CenterForOpenScience/pydocx.png?branch=master
+ :align: left
+ :target: https://travis-ci.org/CenterForOpenScience/pydocx
+
+* `Installation <https://pydocx.readthedocs.org/en/latest/installation.html>`_
+* `Documentation <https://pydocx.readthedocs.org>`_
+* `Release Notes <https://pydocx.readthedocs.org/en/latest/release_notes.html>`_
+* `Github Page <https://github.com/CenterForOpenScience/pydocx>`_
+* `Issue Tracking <https://github.com/CenterForOpenScience/pydocx/issues>`_
+
+PyDocX is a tool
+that can export
+MS Word documents (Office Open XML)
+into different markup languages.
+Currently,
+only HTML is supported.
+You can extend
+any of the available exporters
+to customize it to your needs.
+This includes extending
+the base exporter
+to add support
+for a markup language
+or format
+that is not supported.
+
+To get started using PyDocX,
+see the `Usage <https://pydocx.readthedocs.org/en/latest/usage.html>`_
+guide
+and also
+`Extending PyDocX <https://pydocx.readthedocs.org/en/latest/extending.html>`_.
+
+######
+COS is Hiring!
+######
+
+Want to help save science? Want to get paid to develop free, open source software? `Check out our openings! <http://cos.io/jobs>`_
+
+%package -n python3-PyDocX
+Summary: docx (OOXML) to html converter
+Provides: python-PyDocX
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-PyDocX
+######
+PyDocX
+######
+
+.. image:: https://travis-ci.org/CenterForOpenScience/pydocx.png?branch=master
+ :align: left
+ :target: https://travis-ci.org/CenterForOpenScience/pydocx
+
+* `Installation <https://pydocx.readthedocs.org/en/latest/installation.html>`_
+* `Documentation <https://pydocx.readthedocs.org>`_
+* `Release Notes <https://pydocx.readthedocs.org/en/latest/release_notes.html>`_
+* `Github Page <https://github.com/CenterForOpenScience/pydocx>`_
+* `Issue Tracking <https://github.com/CenterForOpenScience/pydocx/issues>`_
+
+PyDocX is a tool
+that can export
+MS Word documents (Office Open XML)
+into different markup languages.
+Currently,
+only HTML is supported.
+You can extend
+any of the available exporters
+to customize it to your needs.
+This includes extending
+the base exporter
+to add support
+for a markup language
+or format
+that is not supported.
+
+To get started using PyDocX,
+see the `Usage <https://pydocx.readthedocs.org/en/latest/usage.html>`_
+guide
+and also
+`Extending PyDocX <https://pydocx.readthedocs.org/en/latest/extending.html>`_.
+
+######
+COS is Hiring!
+######
+
+Want to help save science? Want to get paid to develop free, open source software? `Check out our openings! <http://cos.io/jobs>`_
+
+%package help
+Summary: Development documents and examples for PyDocX
+Provides: python3-PyDocX-doc
+%description help
+######
+PyDocX
+######
+
+.. image:: https://travis-ci.org/CenterForOpenScience/pydocx.png?branch=master
+ :align: left
+ :target: https://travis-ci.org/CenterForOpenScience/pydocx
+
+* `Installation <https://pydocx.readthedocs.org/en/latest/installation.html>`_
+* `Documentation <https://pydocx.readthedocs.org>`_
+* `Release Notes <https://pydocx.readthedocs.org/en/latest/release_notes.html>`_
+* `Github Page <https://github.com/CenterForOpenScience/pydocx>`_
+* `Issue Tracking <https://github.com/CenterForOpenScience/pydocx/issues>`_
+
+PyDocX is a tool
+that can export
+MS Word documents (Office Open XML)
+into different markup languages.
+Currently,
+only HTML is supported.
+You can extend
+any of the available exporters
+to customize it to your needs.
+This includes extending
+the base exporter
+to add support
+for a markup language
+or format
+that is not supported.
+
+To get started using PyDocX,
+see the `Usage <https://pydocx.readthedocs.org/en/latest/usage.html>`_
+guide
+and also
+`Extending PyDocX <https://pydocx.readthedocs.org/en/latest/extending.html>`_.
+
+######
+COS is Hiring!
+######
+
+Want to help save science? Want to get paid to develop free, open source software? `Check out our openings! <http://cos.io/jobs>`_
+
+%prep
+%autosetup -n PyDocX-0.9.10
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-PyDocX -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.10-1
+- Package Spec generated