summaryrefslogtreecommitdiff
path: root/python-pygame-menu.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pygame-menu.spec')
-rw-r--r--python-pygame-menu.spec79
1 files changed, 79 insertions, 0 deletions
diff --git a/python-pygame-menu.spec b/python-pygame-menu.spec
new file mode 100644
index 0000000..8853d54
--- /dev/null
+++ b/python-pygame-menu.spec
@@ -0,0 +1,79 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pygame-menu
+Version: 4.4.3
+Release: 1
+Summary: A menu for pygame. Simple, and easy to use
+License: MIT
+URL: https://pygame-menu.readthedocs.io
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8c/e1/1a08661c422df56622f9618be268c671a9a9fde7ee532a9f8d2e2e1da13b/pygame-menu-4.4.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-pygame
+Requires: python3-pyperclip
+Requires: python3-typing-extensions
+Requires: python3-sphinx
+Requires: python3-sphinx-autodoc-typehints
+Requires: python3-sphinx-rtd-theme
+Requires: python3-nose2[coverage_plugin]
+
+%description
+
+
+%package -n python3-pygame-menu
+Summary: A menu for pygame. Simple, and easy to use
+Provides: python-pygame-menu
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pygame-menu
+
+
+%package help
+Summary: Development documents and examples for pygame-menu
+Provides: python3-pygame-menu-doc
+%description help
+
+
+%prep
+%autosetup -n pygame-menu-4.4.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pygame-menu -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 4.4.3-1
+- Package Spec generated