summaryrefslogtreecommitdiff
path: root/python-pylibsrtp.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pylibsrtp.spec')
-rw-r--r--python-pylibsrtp.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-pylibsrtp.spec b/python-pylibsrtp.spec
new file mode 100644
index 0000000..a81606f
--- /dev/null
+++ b/python-pylibsrtp.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pylibsrtp
+Version: 0.8.0
+Release: 1
+Summary: Python wrapper around the libsrtp library
+License: BSD
+URL: https://github.com/aiortc/pylibsrtp
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/85/74/ee25343f0876e0a703c1dcf24cc7909f83dca2ab9458bab7196794ab35c3/pylibsrtp-0.8.0.tar.gz
+
+Requires: python3-cffi
+
+%description
+|rtd| |pypi-v| |pypi-pyversions| |pypi-l| |pypi-wheel| |tests| |codecov|
+
+%package -n python3-pylibsrtp
+Summary: Python wrapper around the libsrtp library
+Provides: python-pylibsrtp
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-pylibsrtp
+|rtd| |pypi-v| |pypi-pyversions| |pypi-l| |pypi-wheel| |tests| |codecov|
+
+%package help
+Summary: Development documents and examples for pylibsrtp
+Provides: python3-pylibsrtp-doc
+%description help
+|rtd| |pypi-v| |pypi-pyversions| |pypi-l| |pypi-wheel| |tests| |codecov|
+
+%prep
+%autosetup -n pylibsrtp-0.8.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pylibsrtp -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.0-1
+- Package Spec generated