summaryrefslogtreecommitdiff
path: root/python-pyorbital.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pyorbital.spec')
-rw-r--r--python-pyorbital.spec90
1 files changed, 90 insertions, 0 deletions
diff --git a/python-pyorbital.spec b/python-pyorbital.spec
new file mode 100644
index 0000000..6cb94e9
--- /dev/null
+++ b/python-pyorbital.spec
@@ -0,0 +1,90 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyorbital
+Version: 1.7.3
+Release: 1
+Summary: Orbital parameters and astronomical computations in Python
+License: GNU General Public License v3 or later (GPLv3+)
+URL: https://github.com/pytroll/pyorbital
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/10/2a/d9a09fbcb541c62f665c7798101f1441ac13202d048b393e5e9a372e224d/pyorbital-1.7.3.tar.gz
+BuildArch: noarch
+
+
+%description
+[![Build status](https://github.com/pytroll/pyorbital/workflows/CI/badge.svg?branch=main)](https://github.com/pytroll/pyorbital/workflows/CI/badge.svg?branch=main)
+[![Coverage Status](https://coveralls.io/repos/github/pytroll/pyorbital/badge.svg?branch=main)](https://coveralls.io/github/pytroll/pyorbital?branch=main)
+[![PyPI version](https://badge.fury.io/py/pyorbital.svg)](https://badge.fury.io/py/pyorbital)
+[![DOI](https://zenodo.org/badge/DOI/10.5281/zenodo.6078954.svg)](https://doi.org/10.5281/zenodo.6078954)
+This is the Pyorbital, a Python package for computing orbital parameters from TLE
+files, and making various astronomical computations.
+It is part of the Pytroll project: http://pytroll.org
+
+%package -n python3-pyorbital
+Summary: Orbital parameters and astronomical computations in Python
+Provides: python-pyorbital
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyorbital
+[![Build status](https://github.com/pytroll/pyorbital/workflows/CI/badge.svg?branch=main)](https://github.com/pytroll/pyorbital/workflows/CI/badge.svg?branch=main)
+[![Coverage Status](https://coveralls.io/repos/github/pytroll/pyorbital/badge.svg?branch=main)](https://coveralls.io/github/pytroll/pyorbital?branch=main)
+[![PyPI version](https://badge.fury.io/py/pyorbital.svg)](https://badge.fury.io/py/pyorbital)
+[![DOI](https://zenodo.org/badge/DOI/10.5281/zenodo.6078954.svg)](https://doi.org/10.5281/zenodo.6078954)
+This is the Pyorbital, a Python package for computing orbital parameters from TLE
+files, and making various astronomical computations.
+It is part of the Pytroll project: http://pytroll.org
+
+%package help
+Summary: Development documents and examples for pyorbital
+Provides: python3-pyorbital-doc
+%description help
+[![Build status](https://github.com/pytroll/pyorbital/workflows/CI/badge.svg?branch=main)](https://github.com/pytroll/pyorbital/workflows/CI/badge.svg?branch=main)
+[![Coverage Status](https://coveralls.io/repos/github/pytroll/pyorbital/badge.svg?branch=main)](https://coveralls.io/github/pytroll/pyorbital?branch=main)
+[![PyPI version](https://badge.fury.io/py/pyorbital.svg)](https://badge.fury.io/py/pyorbital)
+[![DOI](https://zenodo.org/badge/DOI/10.5281/zenodo.6078954.svg)](https://doi.org/10.5281/zenodo.6078954)
+This is the Pyorbital, a Python package for computing orbital parameters from TLE
+files, and making various astronomical computations.
+It is part of the Pytroll project: http://pytroll.org
+
+%prep
+%autosetup -n pyorbital-1.7.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyorbital -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.7.3-1
+- Package Spec generated