summaryrefslogtreecommitdiff
path: root/python-pypdf3.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 08:53:42 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 08:53:42 +0000
commit2e172d8ea2a93c1324dd961b6ac8d1d902e22922 (patch)
tree1fecb700fd6e014226664a828b5353471c8b2153 /python-pypdf3.spec
parentd6442c171267ed2b0f6c6f7faaae01521a52bb2b (diff)
automatic import of python-pypdf3
Diffstat (limited to 'python-pypdf3.spec')
-rw-r--r--python-pypdf3.spec123
1 files changed, 123 insertions, 0 deletions
diff --git a/python-pypdf3.spec b/python-pypdf3.spec
new file mode 100644
index 0000000..1476162
--- /dev/null
+++ b/python-pypdf3.spec
@@ -0,0 +1,123 @@
+%global _empty_manifest_terminate_build 0
+Name: python-PyPDF3
+Version: 1.0.6
+Release: 1
+Summary: Pure Python PDF toolkit
+License: BSD License
+URL: https://github.com/sfneal/PyPDF3
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/38/a7/55aeac6bc35446517ea2f50e9f285a35181cdf0a85e320bff997e2497721/PyPDF3-1.0.6.tar.gz
+BuildArch: noarch
+
+
+%description
+
+A Pure-Python library built as a PDF toolkit. It is capable of:
+
+- extracting document information (title, author, ...)
+- splitting documents page by page
+- merging documents page by page
+- cropping pages
+- merging multiple pages into a single page
+- encrypting and decrypting PDF files
+- and more!
+
+By being Pure-Python, it should run on any Python platform without any
+dependencies on external libraries. It can also work entirely on StringIO
+objects rather than file streams, allowing for PDF manipulation in memory.
+It is therefore a useful tool for websites that manage or manipulate PDFs.
+
+
+
+
+%package -n python3-PyPDF3
+Summary: Pure Python PDF toolkit
+Provides: python-PyPDF3
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-PyPDF3
+
+A Pure-Python library built as a PDF toolkit. It is capable of:
+
+- extracting document information (title, author, ...)
+- splitting documents page by page
+- merging documents page by page
+- cropping pages
+- merging multiple pages into a single page
+- encrypting and decrypting PDF files
+- and more!
+
+By being Pure-Python, it should run on any Python platform without any
+dependencies on external libraries. It can also work entirely on StringIO
+objects rather than file streams, allowing for PDF manipulation in memory.
+It is therefore a useful tool for websites that manage or manipulate PDFs.
+
+
+
+
+%package help
+Summary: Development documents and examples for PyPDF3
+Provides: python3-PyPDF3-doc
+%description help
+
+A Pure-Python library built as a PDF toolkit. It is capable of:
+
+- extracting document information (title, author, ...)
+- splitting documents page by page
+- merging documents page by page
+- cropping pages
+- merging multiple pages into a single page
+- encrypting and decrypting PDF files
+- and more!
+
+By being Pure-Python, it should run on any Python platform without any
+dependencies on external libraries. It can also work entirely on StringIO
+objects rather than file streams, allowing for PDF manipulation in memory.
+It is therefore a useful tool for websites that manage or manipulate PDFs.
+
+
+
+
+%prep
+%autosetup -n PyPDF3-1.0.6
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-PyPDF3 -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.6-1
+- Package Spec generated