summaryrefslogtreecommitdiff
path: root/python-pyperformance.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pyperformance.spec')
-rw-r--r--python-pyperformance.spec159
1 files changed, 159 insertions, 0 deletions
diff --git a/python-pyperformance.spec b/python-pyperformance.spec
new file mode 100644
index 0000000..29ba56d
--- /dev/null
+++ b/python-pyperformance.spec
@@ -0,0 +1,159 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyperformance
+Version: 1.0.9
+Release: 1
+Summary: Python benchmark suite
+License: MIT
+URL: https://github.com/python/pyperformance
+Source0: https://mirrors.aliyun.com/pypi/web/packages/2b/02/f2b70f75d2dc492a10ce1db1ee3749416d3e55b368741f933b0920caac0c/pyperformance-1.0.9.tar.gz
+BuildArch: noarch
+
+Requires: python3-pyperf
+Requires: python3-packaging
+Requires: python3-tomli
+Requires: python3-tox
+Requires: python3-mypy
+Requires: python3-tomli
+
+%description
+##########################
+The Python Benchmark Suite
+##########################
+
+.. image:: https://img.shields.io/pypi/v/pyperformance.svg
+ :alt: Latest pyperformance release on the Python Cheeseshop (PyPI)
+ :target: https://pypi.python.org/pypi/pyperformance
+
+.. image:: https://github.com/python/pyperformance/actions/workflows/main.yml/badge.svg
+ :alt: Build status of pyperformance on GitHub Actions
+ :target: https://github.com/python/pyperformance/actions
+
+The ``pyperformance`` project is intended to be an authoritative source of
+benchmarks for all Python implementations. The focus is on real-world
+benchmarks, rather than synthetic benchmarks, using whole applications when
+possible.
+
+* `pyperformance documentation <http://pyperformance.readthedocs.io/>`_
+* `pyperformance GitHub project <https://github.com/python/pyperformance>`_
+ (source code, issues)
+* `Download pyperformance on PyPI <https://pypi.python.org/pypi/pyperformance>`_
+
+pyperformance is not tuned for PyPy yet: use the `PyPy benchmarks project
+<https://foss.heptapod.net/pypy/benchmarks>`_ instead to measure PyPy
+performances.
+
+pyperformance is distributed under the MIT license.
+
+
+%package -n python3-pyperformance
+Summary: Python benchmark suite
+Provides: python-pyperformance
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyperformance
+##########################
+The Python Benchmark Suite
+##########################
+
+.. image:: https://img.shields.io/pypi/v/pyperformance.svg
+ :alt: Latest pyperformance release on the Python Cheeseshop (PyPI)
+ :target: https://pypi.python.org/pypi/pyperformance
+
+.. image:: https://github.com/python/pyperformance/actions/workflows/main.yml/badge.svg
+ :alt: Build status of pyperformance on GitHub Actions
+ :target: https://github.com/python/pyperformance/actions
+
+The ``pyperformance`` project is intended to be an authoritative source of
+benchmarks for all Python implementations. The focus is on real-world
+benchmarks, rather than synthetic benchmarks, using whole applications when
+possible.
+
+* `pyperformance documentation <http://pyperformance.readthedocs.io/>`_
+* `pyperformance GitHub project <https://github.com/python/pyperformance>`_
+ (source code, issues)
+* `Download pyperformance on PyPI <https://pypi.python.org/pypi/pyperformance>`_
+
+pyperformance is not tuned for PyPy yet: use the `PyPy benchmarks project
+<https://foss.heptapod.net/pypy/benchmarks>`_ instead to measure PyPy
+performances.
+
+pyperformance is distributed under the MIT license.
+
+
+%package help
+Summary: Development documents and examples for pyperformance
+Provides: python3-pyperformance-doc
+%description help
+##########################
+The Python Benchmark Suite
+##########################
+
+.. image:: https://img.shields.io/pypi/v/pyperformance.svg
+ :alt: Latest pyperformance release on the Python Cheeseshop (PyPI)
+ :target: https://pypi.python.org/pypi/pyperformance
+
+.. image:: https://github.com/python/pyperformance/actions/workflows/main.yml/badge.svg
+ :alt: Build status of pyperformance on GitHub Actions
+ :target: https://github.com/python/pyperformance/actions
+
+The ``pyperformance`` project is intended to be an authoritative source of
+benchmarks for all Python implementations. The focus is on real-world
+benchmarks, rather than synthetic benchmarks, using whole applications when
+possible.
+
+* `pyperformance documentation <http://pyperformance.readthedocs.io/>`_
+* `pyperformance GitHub project <https://github.com/python/pyperformance>`_
+ (source code, issues)
+* `Download pyperformance on PyPI <https://pypi.python.org/pypi/pyperformance>`_
+
+pyperformance is not tuned for PyPy yet: use the `PyPy benchmarks project
+<https://foss.heptapod.net/pypy/benchmarks>`_ instead to measure PyPy
+performances.
+
+pyperformance is distributed under the MIT license.
+
+
+%prep
+%autosetup -n pyperformance-1.0.9
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyperformance -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.9-1
+- Package Spec generated