summaryrefslogtreecommitdiff
path: root/python-pyphi.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pyphi.spec')
-rw-r--r--python-pyphi.spec89
1 files changed, 89 insertions, 0 deletions
diff --git a/python-pyphi.spec b/python-pyphi.spec
new file mode 100644
index 0000000..fefd862
--- /dev/null
+++ b/python-pyphi.spec
@@ -0,0 +1,89 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyphi
+Version: 1.2.0
+Release: 1
+Summary: Python library for computing integrated information.
+License: GNU General Public License v3.0
+URL: http://github.com/wmayner/pyphi
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b2/8c/d6f05ac28fbeec247a98e568ede794890f8116557fa29827d00e120dd3ac/pyphi-1.2.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-decorator
+Requires: python3-joblib
+Requires: python3-numpy
+Requires: python3-psutil
+Requires: python3-pyemd
+Requires: python3-pymongo
+Requires: python3-pyyaml
+Requires: python3-redis
+Requires: python3-scipy
+Requires: python3-tblib
+Requires: python3-tqdm
+
+%description
+Mayner WGP, Marshall W, Albantakis L, Findlay G, Marchman R, Tononi G. (2018)
+[PyPhi: A toolbox for integrated information
+theory](https://doi.org/10.1371/journal.pcbi.1006343). PLOS Computational
+
+%package -n python3-pyphi
+Summary: Python library for computing integrated information.
+Provides: python-pyphi
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyphi
+Mayner WGP, Marshall W, Albantakis L, Findlay G, Marchman R, Tononi G. (2018)
+[PyPhi: A toolbox for integrated information
+theory](https://doi.org/10.1371/journal.pcbi.1006343). PLOS Computational
+
+%package help
+Summary: Development documents and examples for pyphi
+Provides: python3-pyphi-doc
+%description help
+Mayner WGP, Marshall W, Albantakis L, Findlay G, Marchman R, Tononi G. (2018)
+[PyPhi: A toolbox for integrated information
+theory](https://doi.org/10.1371/journal.pcbi.1006343). PLOS Computational
+
+%prep
+%autosetup -n pyphi-1.2.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyphi -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.0-1
+- Package Spec generated