summaryrefslogtreecommitdiff
path: root/python-pyplaato.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pyplaato.spec')
-rw-r--r--python-pyplaato.spec270
1 files changed, 270 insertions, 0 deletions
diff --git a/python-pyplaato.spec b/python-pyplaato.spec
new file mode 100644
index 0000000..8df88cb
--- /dev/null
+++ b/python-pyplaato.spec
@@ -0,0 +1,270 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyplaato
+Version: 0.0.18
+Release: 1
+Summary: Asynchronous Python client for getting Plaato Airlock and Keg data
+License: MIT License
+URL: https://github.com/JohNan/pyplaato
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/10/74/f5e6b7635deecf78c19bf47c11c1f4a507c33266995a733f5535fe29c81e/pyplaato-0.0.18.tar.gz
+BuildArch: noarch
+
+
+%description
+# Python API client for fetching Plaato data
+
+Fetches data for the Plaato Keg and Plaato Airlock using the official API handed by [blynk.cc](blynk.cc)
+
+To be able to query the API an `auth_token` is required and which can be obtained by following [these](https://plaato.zendesk.com/hc/en-us/articles/360003234717-Auth-token) instructions
+
+For more information about the available pins that can be retrieved please see the official [docs](https://plaato.zendesk.com/hc/en-us/articles/360003234877-Pins) from Plaato
+
+## Usage
+```
+usage: cli.py [-h] -t AUTH_TOKEN -d {keg,airlock,both} [-u URL] [-k API_KEY]
+
+optional arguments:
+ -h, --help show this help message and exit
+
+required arguments:
+ -t AUTH_TOKEN Auth token received from Plaato
+ -d {keg,airlock}
+
+optional arguments:
+ -u URL Mock url
+ -k API_KEY Header key for mock url
+```
+
+## Available pins
+
+### Keg
+```python
+ BEER_NAME = "v64"
+ PERCENT_BEER_LEFT = "v48"
+ POURING = "v49"
+ BEER_LEFT = "v51"
+ BEER_LEFT_UNIT = "v74"
+ TEMPERATURE = "v56"
+ UNIT_TYPE = "v71"
+ MEASURE_UNIT = "v75"
+ MASS_UNIT = "v73"
+ VOLUME_UNIT = "v82"
+ LAST_POUR = "v59"
+ DATE = "v67"
+ OG = "v65"
+ FG = "v66"
+ ABV = "v68"
+ FIRMWARE_VERSION = "v93"
+ LEAK_DETECTION = "v83"
+ MODE = "v88"
+```
+
+### AirLock
+```python
+ BPM = "v102"
+ TEMPERATURE = "v103"
+ BATCH_VOLUME = "v104"
+ OG = "v105"
+ SG = "v106"
+ ABV = "v107"
+ TEMPERATURE_UNIT = "v108"
+ VOLUME_UNIT = "v109"
+ BUBBLES = "v110"
+ CO2_VOLUME = "v119"
+```
+
+### Disclaimer
+This python library was not made by Plaato. It is not official, not developed, and not supported by Plaato.
+
+
+
+
+%package -n python3-pyplaato
+Summary: Asynchronous Python client for getting Plaato Airlock and Keg data
+Provides: python-pyplaato
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyplaato
+# Python API client for fetching Plaato data
+
+Fetches data for the Plaato Keg and Plaato Airlock using the official API handed by [blynk.cc](blynk.cc)
+
+To be able to query the API an `auth_token` is required and which can be obtained by following [these](https://plaato.zendesk.com/hc/en-us/articles/360003234717-Auth-token) instructions
+
+For more information about the available pins that can be retrieved please see the official [docs](https://plaato.zendesk.com/hc/en-us/articles/360003234877-Pins) from Plaato
+
+## Usage
+```
+usage: cli.py [-h] -t AUTH_TOKEN -d {keg,airlock,both} [-u URL] [-k API_KEY]
+
+optional arguments:
+ -h, --help show this help message and exit
+
+required arguments:
+ -t AUTH_TOKEN Auth token received from Plaato
+ -d {keg,airlock}
+
+optional arguments:
+ -u URL Mock url
+ -k API_KEY Header key for mock url
+```
+
+## Available pins
+
+### Keg
+```python
+ BEER_NAME = "v64"
+ PERCENT_BEER_LEFT = "v48"
+ POURING = "v49"
+ BEER_LEFT = "v51"
+ BEER_LEFT_UNIT = "v74"
+ TEMPERATURE = "v56"
+ UNIT_TYPE = "v71"
+ MEASURE_UNIT = "v75"
+ MASS_UNIT = "v73"
+ VOLUME_UNIT = "v82"
+ LAST_POUR = "v59"
+ DATE = "v67"
+ OG = "v65"
+ FG = "v66"
+ ABV = "v68"
+ FIRMWARE_VERSION = "v93"
+ LEAK_DETECTION = "v83"
+ MODE = "v88"
+```
+
+### AirLock
+```python
+ BPM = "v102"
+ TEMPERATURE = "v103"
+ BATCH_VOLUME = "v104"
+ OG = "v105"
+ SG = "v106"
+ ABV = "v107"
+ TEMPERATURE_UNIT = "v108"
+ VOLUME_UNIT = "v109"
+ BUBBLES = "v110"
+ CO2_VOLUME = "v119"
+```
+
+### Disclaimer
+This python library was not made by Plaato. It is not official, not developed, and not supported by Plaato.
+
+
+
+
+%package help
+Summary: Development documents and examples for pyplaato
+Provides: python3-pyplaato-doc
+%description help
+# Python API client for fetching Plaato data
+
+Fetches data for the Plaato Keg and Plaato Airlock using the official API handed by [blynk.cc](blynk.cc)
+
+To be able to query the API an `auth_token` is required and which can be obtained by following [these](https://plaato.zendesk.com/hc/en-us/articles/360003234717-Auth-token) instructions
+
+For more information about the available pins that can be retrieved please see the official [docs](https://plaato.zendesk.com/hc/en-us/articles/360003234877-Pins) from Plaato
+
+## Usage
+```
+usage: cli.py [-h] -t AUTH_TOKEN -d {keg,airlock,both} [-u URL] [-k API_KEY]
+
+optional arguments:
+ -h, --help show this help message and exit
+
+required arguments:
+ -t AUTH_TOKEN Auth token received from Plaato
+ -d {keg,airlock}
+
+optional arguments:
+ -u URL Mock url
+ -k API_KEY Header key for mock url
+```
+
+## Available pins
+
+### Keg
+```python
+ BEER_NAME = "v64"
+ PERCENT_BEER_LEFT = "v48"
+ POURING = "v49"
+ BEER_LEFT = "v51"
+ BEER_LEFT_UNIT = "v74"
+ TEMPERATURE = "v56"
+ UNIT_TYPE = "v71"
+ MEASURE_UNIT = "v75"
+ MASS_UNIT = "v73"
+ VOLUME_UNIT = "v82"
+ LAST_POUR = "v59"
+ DATE = "v67"
+ OG = "v65"
+ FG = "v66"
+ ABV = "v68"
+ FIRMWARE_VERSION = "v93"
+ LEAK_DETECTION = "v83"
+ MODE = "v88"
+```
+
+### AirLock
+```python
+ BPM = "v102"
+ TEMPERATURE = "v103"
+ BATCH_VOLUME = "v104"
+ OG = "v105"
+ SG = "v106"
+ ABV = "v107"
+ TEMPERATURE_UNIT = "v108"
+ VOLUME_UNIT = "v109"
+ BUBBLES = "v110"
+ CO2_VOLUME = "v119"
+```
+
+### Disclaimer
+This python library was not made by Plaato. It is not official, not developed, and not supported by Plaato.
+
+
+
+
+%prep
+%autosetup -n pyplaato-0.0.18
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyplaato -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.18-1
+- Package Spec generated