summaryrefslogtreecommitdiff
path: root/python-pypoint.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-17 03:16:38 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-17 03:16:38 +0000
commit43d7eac37bb6acf57507e16c125046c298b37032 (patch)
treed4b59c9254e0829f6169d3fedbc4d6cd1ba19c8e /python-pypoint.spec
parent90db545acfcffe72cfb678b4a790084dd97cda74 (diff)
automatic import of python-pypoint
Diffstat (limited to 'python-pypoint.spec')
-rw-r--r--python-pypoint.spec99
1 files changed, 99 insertions, 0 deletions
diff --git a/python-pypoint.spec b/python-pypoint.spec
new file mode 100644
index 0000000..7c6d3ee
--- /dev/null
+++ b/python-pypoint.spec
@@ -0,0 +1,99 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pypoint
+Version: 2.3.0
+Release: 1
+Summary: API for Minut Point
+License: MIT License
+URL: https://github.com/fredrike/pypoint
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9b/6e/a55044d6a61912beaae50218d5c805cdaba26cc0e786898d7600fb167c00/pypoint-2.3.0.tar.gz
+BuildArch: noarch
+
+
+%description
+# PyPoint Python package for the Minut Point
+![licence](https://img.shields.io/pypi/l/pypoint) ![pypi-version](https://img.shields.io/pypi/v/pypoint) ![pypi-dl](https://img.shields.io/pypi/dw/pypoint)
+
+Used by [Home Assistant](https://www.home-assistant.io/integrations/point).
+
+The `pyPoint` library enables Python integration with the Minut Point. To connect with Point, you will have to sign up for a developer account and get a client_id and client_secret with the callback url configured as your `base_url + /api/minut`, e.g. http://localhost:8123/api/minut.
+
+
+
+
+
+%package -n python3-pypoint
+Summary: API for Minut Point
+Provides: python-pypoint
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pypoint
+# PyPoint Python package for the Minut Point
+![licence](https://img.shields.io/pypi/l/pypoint) ![pypi-version](https://img.shields.io/pypi/v/pypoint) ![pypi-dl](https://img.shields.io/pypi/dw/pypoint)
+
+Used by [Home Assistant](https://www.home-assistant.io/integrations/point).
+
+The `pyPoint` library enables Python integration with the Minut Point. To connect with Point, you will have to sign up for a developer account and get a client_id and client_secret with the callback url configured as your `base_url + /api/minut`, e.g. http://localhost:8123/api/minut.
+
+
+
+
+
+%package help
+Summary: Development documents and examples for pypoint
+Provides: python3-pypoint-doc
+%description help
+# PyPoint Python package for the Minut Point
+![licence](https://img.shields.io/pypi/l/pypoint) ![pypi-version](https://img.shields.io/pypi/v/pypoint) ![pypi-dl](https://img.shields.io/pypi/dw/pypoint)
+
+Used by [Home Assistant](https://www.home-assistant.io/integrations/point).
+
+The `pyPoint` library enables Python integration with the Minut Point. To connect with Point, you will have to sign up for a developer account and get a client_id and client_secret with the callback url configured as your `base_url + /api/minut`, e.g. http://localhost:8123/api/minut.
+
+
+
+
+
+%prep
+%autosetup -n pypoint-2.3.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pypoint -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 2.3.0-1
+- Package Spec generated