summaryrefslogtreecommitdiff
path: root/python-pyprobables.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-31 05:10:49 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-31 05:10:49 +0000
commitd1f749eb555b48e33d83de550c6981944be36cb2 (patch)
tree04667660fc3222d509ff8f2c1bb18edf73adf076 /python-pyprobables.spec
parent05f586313e5e588dd7b4774c5da641a4ec65f619 (diff)
automatic import of python-pyprobables
Diffstat (limited to 'python-pyprobables.spec')
-rw-r--r--python-pyprobables.spec105
1 files changed, 105 insertions, 0 deletions
diff --git a/python-pyprobables.spec b/python-pyprobables.spec
new file mode 100644
index 0000000..2253c0a
--- /dev/null
+++ b/python-pyprobables.spec
@@ -0,0 +1,105 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyprobables
+Version: 0.5.7
+Release: 1
+Summary: Probabilistic data structures in python
+License: MIT
+URL: https://github.com/barrust/pyprobables
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/18/27/699bb27adf2636a826d76529a85bf043b7c09bf34a56b08fa5b4af512126/pyprobables-0.5.7.tar.gz
+BuildArch: noarch
+
+
+%description
+**pyprobables** is a pure-python library for probabilistic data structures.
+The goal is to provide the developer with a pure-python implementation of
+common probabilistic data-structures to use in their work.
+To achieve better raw performance, it is recommended supplying an alternative
+hashing algorithm that has been compiled in C. This could include using the
+md5 and sha512 algorithms provided or installing a third party package and
+writing your own hashing strategy. Some options include the murmur hash
+`mmh3 <https://github.com/hajimes/mmh3>`__ or those from the
+`pyhash <https://github.com/flier/pyfasthash>`__ library. Each data object in
+**pyprobables** makes it easy to pass in a custom hashing function.
+Read more about how to use `Supplying a pre-defined, alternative hashing strategies`_
+or `Defining hashing function using the provided decorators`_.
+
+%package -n python3-pyprobables
+Summary: Probabilistic data structures in python
+Provides: python-pyprobables
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyprobables
+**pyprobables** is a pure-python library for probabilistic data structures.
+The goal is to provide the developer with a pure-python implementation of
+common probabilistic data-structures to use in their work.
+To achieve better raw performance, it is recommended supplying an alternative
+hashing algorithm that has been compiled in C. This could include using the
+md5 and sha512 algorithms provided or installing a third party package and
+writing your own hashing strategy. Some options include the murmur hash
+`mmh3 <https://github.com/hajimes/mmh3>`__ or those from the
+`pyhash <https://github.com/flier/pyfasthash>`__ library. Each data object in
+**pyprobables** makes it easy to pass in a custom hashing function.
+Read more about how to use `Supplying a pre-defined, alternative hashing strategies`_
+or `Defining hashing function using the provided decorators`_.
+
+%package help
+Summary: Development documents and examples for pyprobables
+Provides: python3-pyprobables-doc
+%description help
+**pyprobables** is a pure-python library for probabilistic data structures.
+The goal is to provide the developer with a pure-python implementation of
+common probabilistic data-structures to use in their work.
+To achieve better raw performance, it is recommended supplying an alternative
+hashing algorithm that has been compiled in C. This could include using the
+md5 and sha512 algorithms provided or installing a third party package and
+writing your own hashing strategy. Some options include the murmur hash
+`mmh3 <https://github.com/hajimes/mmh3>`__ or those from the
+`pyhash <https://github.com/flier/pyfasthash>`__ library. Each data object in
+**pyprobables** makes it easy to pass in a custom hashing function.
+Read more about how to use `Supplying a pre-defined, alternative hashing strategies`_
+or `Defining hashing function using the provided decorators`_.
+
+%prep
+%autosetup -n pyprobables-0.5.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyprobables -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.7-1
+- Package Spec generated