summaryrefslogtreecommitdiff
path: root/python-pyproject-toml.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pyproject-toml.spec')
-rw-r--r--python-pyproject-toml.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-pyproject-toml.spec b/python-pyproject-toml.spec
new file mode 100644
index 0000000..9ffc30b
--- /dev/null
+++ b/python-pyproject-toml.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyproject-toml
+Version: 0.0.10
+Release: 1
+Summary: Project intend to implement PEP 517, 518, 621, 631 and so on.
+License: MIT
+URL: https://github.com/pyproject-toml/pyproject-toml
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/05/82/f2ab4c65c33103e62fdb2db8fce0db5d5061b8fab15e266a08fe387418f4/pyproject-toml-0.0.10.tar.gz
+BuildArch: noarch
+
+
+%description
+Project intend to implement PEP 517, 518, 621, 631 and so on.
+
+%package -n python3-pyproject-toml
+Summary: Project intend to implement PEP 517, 518, 621, 631 and so on.
+Provides: python-pyproject-toml
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyproject-toml
+Project intend to implement PEP 517, 518, 621, 631 and so on.
+
+%package help
+Summary: Development documents and examples for pyproject-toml
+Provides: python3-pyproject-toml-doc
+%description help
+Project intend to implement PEP 517, 518, 621, 631 and so on.
+
+%prep
+%autosetup -n pyproject-toml-0.0.10
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyproject-toml -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.10-1
+- Package Spec generated