summaryrefslogtreecommitdiff
path: root/python-pyqbdi.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pyqbdi.spec')
-rw-r--r--python-pyqbdi.spec116
1 files changed, 116 insertions, 0 deletions
diff --git a/python-pyqbdi.spec b/python-pyqbdi.spec
new file mode 100644
index 0000000..1ed9677
--- /dev/null
+++ b/python-pyqbdi.spec
@@ -0,0 +1,116 @@
+%global _empty_manifest_terminate_build 0
+Name: python-PyQBDI
+Version: 0.10.0
+Release: 1
+Summary: Python binding for QBDI
+License: apache2
+URL: https://qbdi.quarkslab.com/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f5/00/accf1ede524cc5320ad8d8d4d8e985952b8ccdcf3ebd83de714b4739ed3c/PyQBDI-0.10.0.tar.gz
+
+
+%description
+QuarkslaB Dynamic binary Instrumentation (QBDI) is a modular, cross-platform and cross-architecture
+DBI framework. It aims to support Linux, macOS, Android, iOS and Windows operating systems running on
+x86, x86-64, ARM and AArch64 architectures. In addition of C/C++ API, Python and JS/frida bindings are
+available to script QBDI. Information about what is a DBI framework and how QBDI
+works can be found in the `documentation introduction <https://qbdi.readthedocs.io/en/stable/intro.html>`_.
+QBDI modularity means it doesn't contain a preferred injection method and it is designed to be
+used in conjunction with an external injection tool. QBDI includes a tiny (``LD_PRELOAD`` based)
+Linux and macOS injector for dynamic executables (QBDIPreload).
+QBDI is also fully integrated with `Frida <https://frida.re>`_, a reference dynamic instrumentation toolkit,
+allowing anybody to use their combined powers.
+A current limitation is that QBDI doesn't handle signals, multithreading (it doesn't deal with new
+threads creation) and C++ exception mechanisms.
+However, those system-dependent features will probably not be part of the core library (KISS),
+and should be integrated as a new layer (to be determined how).
+Status
+
+%package -n python3-PyQBDI
+Summary: Python binding for QBDI
+Provides: python-PyQBDI
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-PyQBDI
+QuarkslaB Dynamic binary Instrumentation (QBDI) is a modular, cross-platform and cross-architecture
+DBI framework. It aims to support Linux, macOS, Android, iOS and Windows operating systems running on
+x86, x86-64, ARM and AArch64 architectures. In addition of C/C++ API, Python and JS/frida bindings are
+available to script QBDI. Information about what is a DBI framework and how QBDI
+works can be found in the `documentation introduction <https://qbdi.readthedocs.io/en/stable/intro.html>`_.
+QBDI modularity means it doesn't contain a preferred injection method and it is designed to be
+used in conjunction with an external injection tool. QBDI includes a tiny (``LD_PRELOAD`` based)
+Linux and macOS injector for dynamic executables (QBDIPreload).
+QBDI is also fully integrated with `Frida <https://frida.re>`_, a reference dynamic instrumentation toolkit,
+allowing anybody to use their combined powers.
+A current limitation is that QBDI doesn't handle signals, multithreading (it doesn't deal with new
+threads creation) and C++ exception mechanisms.
+However, those system-dependent features will probably not be part of the core library (KISS),
+and should be integrated as a new layer (to be determined how).
+Status
+
+%package help
+Summary: Development documents and examples for PyQBDI
+Provides: python3-PyQBDI-doc
+%description help
+QuarkslaB Dynamic binary Instrumentation (QBDI) is a modular, cross-platform and cross-architecture
+DBI framework. It aims to support Linux, macOS, Android, iOS and Windows operating systems running on
+x86, x86-64, ARM and AArch64 architectures. In addition of C/C++ API, Python and JS/frida bindings are
+available to script QBDI. Information about what is a DBI framework and how QBDI
+works can be found in the `documentation introduction <https://qbdi.readthedocs.io/en/stable/intro.html>`_.
+QBDI modularity means it doesn't contain a preferred injection method and it is designed to be
+used in conjunction with an external injection tool. QBDI includes a tiny (``LD_PRELOAD`` based)
+Linux and macOS injector for dynamic executables (QBDIPreload).
+QBDI is also fully integrated with `Frida <https://frida.re>`_, a reference dynamic instrumentation toolkit,
+allowing anybody to use their combined powers.
+A current limitation is that QBDI doesn't handle signals, multithreading (it doesn't deal with new
+threads creation) and C++ exception mechanisms.
+However, those system-dependent features will probably not be part of the core library (KISS),
+and should be integrated as a new layer (to be determined how).
+Status
+
+%prep
+%autosetup -n PyQBDI-0.10.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-PyQBDI -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.10.0-1
+- Package Spec generated