summaryrefslogtreecommitdiff
path: root/python-pyramid-nacl-session.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-17 03:12:53 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-17 03:12:53 +0000
commit16aecce74ce70880515fd7e5f7a46ac0bb22b0d1 (patch)
tree960c7be7667e9d8a15e4db15de89030923fe7d2b /python-pyramid-nacl-session.spec
parentbe6273869de34a4565464567273e74c37ccfa643 (diff)
automatic import of python-pyramid-nacl-session
Diffstat (limited to 'python-pyramid-nacl-session.spec')
-rw-r--r--python-pyramid-nacl-session.spec92
1 files changed, 92 insertions, 0 deletions
diff --git a/python-pyramid-nacl-session.spec b/python-pyramid-nacl-session.spec
new file mode 100644
index 0000000..af56b17
--- /dev/null
+++ b/python-pyramid-nacl-session.spec
@@ -0,0 +1,92 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyramid-nacl-session
+Version: 1.0.0
+Release: 1
+Summary: Encrypted session cookie serializer for Pyramid
+License: BSD-derived (http://www.repoze.org/LICENSE.txt)
+URL: https://github.com/Pylons/pyramid_nacl_session
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/70/af/ce82123c841144f476f89857840a0ba590df289484b531b4cbf997487efb/pyramid_nacl_session-1.0.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-pyramid
+Requires: python3-PyNaCl
+Requires: python3-Sphinx
+Requires: python3-pylons-sphinx-themes
+Requires: python3-WebTest
+Requires: python3-pytest
+Requires: python3-pytest-cover
+Requires: python3-coverage
+
+%description
+This Pyramid add-on defines an encrypting, pickle-based cookie serializer,
+using ``PyNaCl`` [1] to generate the symmetric encryption for the cookie state.
+[1] https://pynacl.readthedocs.io/en/latest/secret/
+See: ``docs/index.rst`` for the documentation.
+ Initial development of this library was sponsored by ZeOmega Inc.
+
+%package -n python3-pyramid-nacl-session
+Summary: Encrypted session cookie serializer for Pyramid
+Provides: python-pyramid-nacl-session
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyramid-nacl-session
+This Pyramid add-on defines an encrypting, pickle-based cookie serializer,
+using ``PyNaCl`` [1] to generate the symmetric encryption for the cookie state.
+[1] https://pynacl.readthedocs.io/en/latest/secret/
+See: ``docs/index.rst`` for the documentation.
+ Initial development of this library was sponsored by ZeOmega Inc.
+
+%package help
+Summary: Development documents and examples for pyramid-nacl-session
+Provides: python3-pyramid-nacl-session-doc
+%description help
+This Pyramid add-on defines an encrypting, pickle-based cookie serializer,
+using ``PyNaCl`` [1] to generate the symmetric encryption for the cookie state.
+[1] https://pynacl.readthedocs.io/en/latest/secret/
+See: ``docs/index.rst`` for the documentation.
+ Initial development of this library was sponsored by ZeOmega Inc.
+
+%prep
+%autosetup -n pyramid-nacl-session-1.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyramid-nacl-session -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
+- Package Spec generated