summaryrefslogtreecommitdiff
path: root/python-pyshuttle.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pyshuttle.spec')
-rw-r--r--python-pyshuttle.spec277
1 files changed, 277 insertions, 0 deletions
diff --git a/python-pyshuttle.spec b/python-pyshuttle.spec
new file mode 100644
index 0000000..8b56460
--- /dev/null
+++ b/python-pyshuttle.spec
@@ -0,0 +1,277 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyshuttle
+Version: 0.3.4
+Release: 1
+Summary: Cross-chain atomic swaps between the networks of two cryptocurrencies.
+License: AGPL-3.0
+URL: https://github.com/meherett/shuttle
+Source0: https://mirrors.aliyun.com/pypi/web/packages/67/75/e4df3055294a0d6393b3002e741868421522627c5020790ccacbcaba95cc/pyshuttle-0.3.4.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+Requires: python3-cryptos
+Requires: python3-chainside-btcpy
+Requires: python3-mnemonic
+Requires: python3-py-equity
+Requires: python3-click
+Requires: python3-pybytom
+Requires: python3-six
+Requires: python3-sphinx
+Requires: python3-sphinx-rtd-theme
+Requires: python3-sphinx-click
+Requires: python3-pytest
+Requires: python3-pytest-cov
+
+%description
+# Shuttle
+
+[![Build Status](https://travis-ci.org/meherett/shuttle.svg?branch=master)](https://travis-ci.org/meherett/shuttle?branch=master)
+[![PyPI Version](https://img.shields.io/pypi/v/pyshuttle.svg?color=blue)](https://pypi.org/project/pyshuttle)
+[![Documentation Status](https://readthedocs.org/projects/shuttle/badge/?version=latest)](https://shuttle.readthedocs.io/en/latest/?badge=latest)
+[![Coverage Status](https://coveralls.io/repos/github/meherett/shuttle/badge.svg?branch=master&kill_cache=1)](https://coveralls.io/github/meherett/shuttle?branch=master)
+
+Shuttle is a python library for cross-chain atomic swaps between the networks of two cryptocurrencies. Cross-chain atomic swaps are the cheapest and most secure way to swap cryptocurrencies. It’s a brand new decentralized payment environment based on Hash Time Lock Contracts (HTLCs) protocol. [Documentation](https://shuttle.readthedocs.io)
+
+## Available Cryptocurrencies
+
+Shuttle has the following available cryptocurrencies to swap:
+
+| Cryptocurrencies | Mainnet | Testnet | Solonet |
+| ------------------------------------------------------- | :-----: | :-----: | :-----: |
+| [Bitcoin](https://github.com/bitcoin/bitcoin) `BTC` | Yes | Yes | None |
+| [Bytom](https://github.com/bytom/bytom) `BTM`, `Assets` | Yes | No | No |
+
+## Dependencies
+
+* [bytom-wallet-desktop](https://bytom.io/en/wallet/) - version [1.1.0](https://github.com/Bytom/bytom/releases/tag/v1.1.0) or greater.
+* [pip](https://pypi.org/project/pip/) - To install packages from the Python Package Index and other indexes.
+* [python3](https://www.python.org/downloads/release/python-368/) version 3.6 or greater.
+
+## Installation
+
+PIP to install shuttle globally. For Linux sudo may be required.
+
+```
+$ pip install pyshuttle
+```
+
+For the versions available, see the [tags on this repository](https://github.com/meherett/shuttle/tags).
+
+## Development
+
+We welcome pull requests. To get started, just fork this repo, clone it locally, and run:
+
+```
+$ pip install -e .[tests] -r requirements.txt
+```
+
+## Testing
+
+Tests are still under development.
+
+You can run the tests with:
+
+```
+$ pytest
+```
+
+Or use `tox` to run the complete suite against the full set of build targets, or pytest to run specific
+tests against a specific version of Python.
+
+## Contributing
+
+Feel free to open an issue if you find a problem, or a pull request if you've solved an issue.
+
+## License
+
+Distributed under the [AGPL-3.0](https://github.com/meherett/shuttle/blob/master/LICENSE) license. See ``LICENSE`` for more information.
+
+
+
+
+%package -n python3-pyshuttle
+Summary: Cross-chain atomic swaps between the networks of two cryptocurrencies.
+Provides: python-pyshuttle
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyshuttle
+# Shuttle
+
+[![Build Status](https://travis-ci.org/meherett/shuttle.svg?branch=master)](https://travis-ci.org/meherett/shuttle?branch=master)
+[![PyPI Version](https://img.shields.io/pypi/v/pyshuttle.svg?color=blue)](https://pypi.org/project/pyshuttle)
+[![Documentation Status](https://readthedocs.org/projects/shuttle/badge/?version=latest)](https://shuttle.readthedocs.io/en/latest/?badge=latest)
+[![Coverage Status](https://coveralls.io/repos/github/meherett/shuttle/badge.svg?branch=master&kill_cache=1)](https://coveralls.io/github/meherett/shuttle?branch=master)
+
+Shuttle is a python library for cross-chain atomic swaps between the networks of two cryptocurrencies. Cross-chain atomic swaps are the cheapest and most secure way to swap cryptocurrencies. It’s a brand new decentralized payment environment based on Hash Time Lock Contracts (HTLCs) protocol. [Documentation](https://shuttle.readthedocs.io)
+
+## Available Cryptocurrencies
+
+Shuttle has the following available cryptocurrencies to swap:
+
+| Cryptocurrencies | Mainnet | Testnet | Solonet |
+| ------------------------------------------------------- | :-----: | :-----: | :-----: |
+| [Bitcoin](https://github.com/bitcoin/bitcoin) `BTC` | Yes | Yes | None |
+| [Bytom](https://github.com/bytom/bytom) `BTM`, `Assets` | Yes | No | No |
+
+## Dependencies
+
+* [bytom-wallet-desktop](https://bytom.io/en/wallet/) - version [1.1.0](https://github.com/Bytom/bytom/releases/tag/v1.1.0) or greater.
+* [pip](https://pypi.org/project/pip/) - To install packages from the Python Package Index and other indexes.
+* [python3](https://www.python.org/downloads/release/python-368/) version 3.6 or greater.
+
+## Installation
+
+PIP to install shuttle globally. For Linux sudo may be required.
+
+```
+$ pip install pyshuttle
+```
+
+For the versions available, see the [tags on this repository](https://github.com/meherett/shuttle/tags).
+
+## Development
+
+We welcome pull requests. To get started, just fork this repo, clone it locally, and run:
+
+```
+$ pip install -e .[tests] -r requirements.txt
+```
+
+## Testing
+
+Tests are still under development.
+
+You can run the tests with:
+
+```
+$ pytest
+```
+
+Or use `tox` to run the complete suite against the full set of build targets, or pytest to run specific
+tests against a specific version of Python.
+
+## Contributing
+
+Feel free to open an issue if you find a problem, or a pull request if you've solved an issue.
+
+## License
+
+Distributed under the [AGPL-3.0](https://github.com/meherett/shuttle/blob/master/LICENSE) license. See ``LICENSE`` for more information.
+
+
+
+
+%package help
+Summary: Development documents and examples for pyshuttle
+Provides: python3-pyshuttle-doc
+%description help
+# Shuttle
+
+[![Build Status](https://travis-ci.org/meherett/shuttle.svg?branch=master)](https://travis-ci.org/meherett/shuttle?branch=master)
+[![PyPI Version](https://img.shields.io/pypi/v/pyshuttle.svg?color=blue)](https://pypi.org/project/pyshuttle)
+[![Documentation Status](https://readthedocs.org/projects/shuttle/badge/?version=latest)](https://shuttle.readthedocs.io/en/latest/?badge=latest)
+[![Coverage Status](https://coveralls.io/repos/github/meherett/shuttle/badge.svg?branch=master&kill_cache=1)](https://coveralls.io/github/meherett/shuttle?branch=master)
+
+Shuttle is a python library for cross-chain atomic swaps between the networks of two cryptocurrencies. Cross-chain atomic swaps are the cheapest and most secure way to swap cryptocurrencies. It’s a brand new decentralized payment environment based on Hash Time Lock Contracts (HTLCs) protocol. [Documentation](https://shuttle.readthedocs.io)
+
+## Available Cryptocurrencies
+
+Shuttle has the following available cryptocurrencies to swap:
+
+| Cryptocurrencies | Mainnet | Testnet | Solonet |
+| ------------------------------------------------------- | :-----: | :-----: | :-----: |
+| [Bitcoin](https://github.com/bitcoin/bitcoin) `BTC` | Yes | Yes | None |
+| [Bytom](https://github.com/bytom/bytom) `BTM`, `Assets` | Yes | No | No |
+
+## Dependencies
+
+* [bytom-wallet-desktop](https://bytom.io/en/wallet/) - version [1.1.0](https://github.com/Bytom/bytom/releases/tag/v1.1.0) or greater.
+* [pip](https://pypi.org/project/pip/) - To install packages from the Python Package Index and other indexes.
+* [python3](https://www.python.org/downloads/release/python-368/) version 3.6 or greater.
+
+## Installation
+
+PIP to install shuttle globally. For Linux sudo may be required.
+
+```
+$ pip install pyshuttle
+```
+
+For the versions available, see the [tags on this repository](https://github.com/meherett/shuttle/tags).
+
+## Development
+
+We welcome pull requests. To get started, just fork this repo, clone it locally, and run:
+
+```
+$ pip install -e .[tests] -r requirements.txt
+```
+
+## Testing
+
+Tests are still under development.
+
+You can run the tests with:
+
+```
+$ pytest
+```
+
+Or use `tox` to run the complete suite against the full set of build targets, or pytest to run specific
+tests against a specific version of Python.
+
+## Contributing
+
+Feel free to open an issue if you find a problem, or a pull request if you've solved an issue.
+
+## License
+
+Distributed under the [AGPL-3.0](https://github.com/meherett/shuttle/blob/master/LICENSE) license. See ``LICENSE`` for more information.
+
+
+
+
+%prep
+%autosetup -n pyshuttle-0.3.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyshuttle -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.4-1
+- Package Spec generated