summaryrefslogtreecommitdiff
path: root/python-pysuez.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pysuez.spec')
-rw-r--r--python-pysuez.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-pysuez.spec b/python-pysuez.spec
new file mode 100644
index 0000000..f4dce71
--- /dev/null
+++ b/python-pysuez.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pysuez
+Version: 0.1.30
+Release: 1
+Summary: Get your water consumption data from your Suez account (www.toutsurmoneau.fr or www.eau-olivet.fr)
+License: Apache 2.0
+URL: https://github.com/ooii/pySuez
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/84/45/cccc422ccef8feb8f67bcce0d73c225071797c08b6c1d92461dc1bf16528/pysuez-0.1.30.tar.gz
+BuildArch: noarch
+
+Requires: python3-regex
+Requires: python3-requests
+Requires: python3-datetime
+
+%description
+Get your consumption data from your Suez account (www.toutsurmoneau.fr)
+This work is inspired by the [Sirus](https://github.com/Sirus10)'s [domoticz sensor](https://github.com/Sirus10/domoticz).
+It is also inspired by [`pyLinky`](https://github.com/pirionfr/pyLinky) code from [`Pirionfr`](https://github.com/pirionfr).
+
+%package -n python3-pysuez
+Summary: Get your water consumption data from your Suez account (www.toutsurmoneau.fr or www.eau-olivet.fr)
+Provides: python-pysuez
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pysuez
+Get your consumption data from your Suez account (www.toutsurmoneau.fr)
+This work is inspired by the [Sirus](https://github.com/Sirus10)'s [domoticz sensor](https://github.com/Sirus10/domoticz).
+It is also inspired by [`pyLinky`](https://github.com/pirionfr/pyLinky) code from [`Pirionfr`](https://github.com/pirionfr).
+
+%package help
+Summary: Development documents and examples for pysuez
+Provides: python3-pysuez-doc
+%description help
+Get your consumption data from your Suez account (www.toutsurmoneau.fr)
+This work is inspired by the [Sirus](https://github.com/Sirus10)'s [domoticz sensor](https://github.com/Sirus10/domoticz).
+It is also inspired by [`pyLinky`](https://github.com/pirionfr/pyLinky) code from [`Pirionfr`](https://github.com/pirionfr).
+
+%prep
+%autosetup -n pysuez-0.1.30
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pysuez -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.30-1
+- Package Spec generated