summaryrefslogtreecommitdiff
path: root/python-pytest-salt-factories.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pytest-salt-factories.spec')
-rw-r--r--python-pytest-salt-factories.spec98
1 files changed, 98 insertions, 0 deletions
diff --git a/python-pytest-salt-factories.spec b/python-pytest-salt-factories.spec
new file mode 100644
index 0000000..37a40f6
--- /dev/null
+++ b/python-pytest-salt-factories.spec
@@ -0,0 +1,98 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pytest-salt-factories
+Version: 0.912.2
+Release: 1
+Summary: Pytest Salt Plugin
+License: Apache Software License 2.0
+URL: https://github.com/saltstack/pytest-salt-factories
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/67/98/87d7a4f2a14681ee10e7032c8be0871e966037d650a4c8dfd7b6b75a0d40/pytest-salt-factories-0.912.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-pytest
+Requires: python3-attrs
+Requires: python3-pytest-tempdir
+Requires: python3-pytest-helpers-namespace
+Requires: python3-pytest-skip-markers
+Requires: python3-psutil
+Requires: python3-pyzmq
+Requires: python3-msgpack
+Requires: python3-virtualenv
+Requires: python3-docker
+Requires: python3-furo
+Requires: python3-sphinx
+Requires: python3-sphinx-copybutton
+Requires: python3-sphinx-prompt
+Requires: python3-sphinxcontrib-spelling
+Requires: python3-sphinxcontrib-towncrier
+Requires: python3-pylint
+Requires: python3-saltpylint
+Requires: python3-pyenchant
+Requires: python3-black
+Requires: python3-reorder-python-imports
+Requires: python3-salt
+Requires: python3-docker
+Requires: python3-pytest-subtests
+Requires: python3-pyfakefs
+Requires: python3-pyfakefs
+
+%description
+
+
+%package -n python3-pytest-salt-factories
+Summary: Pytest Salt Plugin
+Provides: python-pytest-salt-factories
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pytest-salt-factories
+
+
+%package help
+Summary: Development documents and examples for pytest-salt-factories
+Provides: python3-pytest-salt-factories-doc
+%description help
+
+
+%prep
+%autosetup -n pytest-salt-factories-0.912.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pytest-salt-factories -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 0.912.2-1
+- Package Spec generated