summaryrefslogtreecommitdiff
path: root/python-pytest-spark.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pytest-spark.spec')
-rw-r--r--python-pytest-spark.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-pytest-spark.spec b/python-pytest-spark.spec
new file mode 100644
index 0000000..6798534
--- /dev/null
+++ b/python-pytest-spark.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pytest-spark
+Version: 0.6.0
+Release: 1
+Summary: pytest plugin to run the tests with support of pyspark.
+License: MIT
+URL: https://github.com/malexer/pytest-spark
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ea/06/0a05e3bb6dbf86a45590d1192236fae6717bfc80d8cfdf1d86ac56af7928/pytest-spark-0.6.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-pytest
+Requires: python3-findspark
+
+%description
+ $ pip install pytest-spark
+
+%package -n python3-pytest-spark
+Summary: pytest plugin to run the tests with support of pyspark.
+Provides: python-pytest-spark
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pytest-spark
+ $ pip install pytest-spark
+
+%package help
+Summary: Development documents and examples for pytest-spark
+Provides: python3-pytest-spark-doc
+%description help
+ $ pip install pytest-spark
+
+%prep
+%autosetup -n pytest-spark-0.6.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pytest-spark -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.0-1
+- Package Spec generated