summaryrefslogtreecommitdiff
path: root/python-pythondata-cpu-cv32e40p.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pythondata-cpu-cv32e40p.spec')
-rw-r--r--python-pythondata-cpu-cv32e40p.spec399
1 files changed, 399 insertions, 0 deletions
diff --git a/python-pythondata-cpu-cv32e40p.spec b/python-pythondata-cpu-cv32e40p.spec
new file mode 100644
index 0000000..940e571
--- /dev/null
+++ b/python-pythondata-cpu-cv32e40p.spec
@@ -0,0 +1,399 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pythondata-cpu-cv32e40p
+Version: 0.0.post152
+Release: 1
+Summary: Python module containing system_verilog files for CV32E40P cpu.
+License: Apache Software License
+URL: https://github.com/litex-hub/pythondata-cpu-cv32e40p
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fe/9f/c4cc5445512eaa02cbbd094b6e3130a50a3306f56bb57ef9c1dc51aa4a07/pythondata-cpu-cv32e40p-0.0.post152.tar.gz
+BuildArch: noarch
+
+
+%description
+# pythondata-cpu-cv32e40p
+
+Non-Python files needed for the cpu cv32e40p packaged
+into a Python module so they can be used with Python libraries and tools.
+
+This is useful for usage with tools like
+[LiteX](https://github.com/enjoy-digital/litex.git).
+
+The data files can be found under the Python module `pythondata_cpu_cv32e40p`. The
+`pythondata_cpu_cv32e40p.data_location` value can be used to find the files on the file
+system.
+
+Example of getting the data file directly;
+```python
+import pythondata_cpu_cv32e40p
+
+my_data_file = "abc.txt"
+
+with open(os.path.join(pythondata_cpu_cv32e40p.data_location, my_data_file)) as f:
+ print(f.read())
+```
+
+Example of getting the data file using `litex.data.find` API;
+```python
+from pythondata_cpu_cv32e40p import data_file
+
+my_data_file = "abc.txt"
+
+with open(data_file(my_data_file)) as f:
+ print(f.read())
+```
+
+
+The data files come from https://github.com/antmicro/cv32e40p
+and are imported using `git subtrees` to the directory
+[pythondata_cpu_cv32e40p/system_verilog](pythondata_cpu_cv32e40p/system_verilog).
+
+
+
+# Installing
+
+## Directly from git repository
+
+### Manually
+
+You can install the package manually, however this is **not** recommended.
+
+```
+git clone https://github.com/litex-hub/pythondata-cpu-cv32e40p.git
+cd pythondata-cpu-cv32e40p
+sudo python setup.py install
+```
+
+### Using [pip](https://pip.pypa.io/) with git repository
+
+You can use [pip](https://pip.pypa.io/) to install the data package directly
+from github using;
+
+```
+pip install --user git+https://github.com/litex-hub/pythondata-cpu-cv32e40p.git
+```
+
+If you want to install for the whole system rather than just the current user,
+you need to remove the `--user` argument and run as sudo like so;
+
+```
+sudo pip install git+https://github.com/litex-hub/pythondata-cpu-cv32e40p.git
+```
+
+You can install a specific revision of the repository using;
+```
+pip install --user git+https://github.com/litex-hub/pythondata-cpu-cv32e40p.git@<tag>
+pip install --user git+https://github.com/litex-hub/pythondata-cpu-cv32e40p.git@<branch>
+pip install --user git+https://github.com/litex-hub/pythondata-cpu-cv32e40p.git@<hash>
+```
+
+### With `requirements.txt` file
+
+Add to your Python `requirements.txt` file using;
+```
+-e git+https://github.com/litex-hub/pythondata-cpu-cv32e40p.git
+```
+
+To use a specific revision of the repository, use the following;
+```
+-e https://github.com/litex-hub/pythondata-cpu-cv32e40p.git@<hash>
+```
+
+## Via [PyPi](https://pypi.org/project/pythondata-cpu-cv32e40p/)
+
+### Using [pip](https://pip.pypa.io/)
+
+```
+pip install --user pythondata-cpu-cv32e40p
+```
+
+### With `requirements.txt` file
+
+Add to your Python `requirements.txt` file using;
+```
+pythondata-cpu-cv32e40p
+```
+
+# Issues and Fixes
+
+This package is autogenerated from the sources in
+<https://github.com/antmicro/cv32e40p>
+using the [pythondata-auto](https://github.com/litex-hub/pythondata-auto)
+toolset. Pull requests and issues on this pythondata repo may not be monitored.
+
+
+%package -n python3-pythondata-cpu-cv32e40p
+Summary: Python module containing system_verilog files for CV32E40P cpu.
+Provides: python-pythondata-cpu-cv32e40p
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pythondata-cpu-cv32e40p
+# pythondata-cpu-cv32e40p
+
+Non-Python files needed for the cpu cv32e40p packaged
+into a Python module so they can be used with Python libraries and tools.
+
+This is useful for usage with tools like
+[LiteX](https://github.com/enjoy-digital/litex.git).
+
+The data files can be found under the Python module `pythondata_cpu_cv32e40p`. The
+`pythondata_cpu_cv32e40p.data_location` value can be used to find the files on the file
+system.
+
+Example of getting the data file directly;
+```python
+import pythondata_cpu_cv32e40p
+
+my_data_file = "abc.txt"
+
+with open(os.path.join(pythondata_cpu_cv32e40p.data_location, my_data_file)) as f:
+ print(f.read())
+```
+
+Example of getting the data file using `litex.data.find` API;
+```python
+from pythondata_cpu_cv32e40p import data_file
+
+my_data_file = "abc.txt"
+
+with open(data_file(my_data_file)) as f:
+ print(f.read())
+```
+
+
+The data files come from https://github.com/antmicro/cv32e40p
+and are imported using `git subtrees` to the directory
+[pythondata_cpu_cv32e40p/system_verilog](pythondata_cpu_cv32e40p/system_verilog).
+
+
+
+# Installing
+
+## Directly from git repository
+
+### Manually
+
+You can install the package manually, however this is **not** recommended.
+
+```
+git clone https://github.com/litex-hub/pythondata-cpu-cv32e40p.git
+cd pythondata-cpu-cv32e40p
+sudo python setup.py install
+```
+
+### Using [pip](https://pip.pypa.io/) with git repository
+
+You can use [pip](https://pip.pypa.io/) to install the data package directly
+from github using;
+
+```
+pip install --user git+https://github.com/litex-hub/pythondata-cpu-cv32e40p.git
+```
+
+If you want to install for the whole system rather than just the current user,
+you need to remove the `--user` argument and run as sudo like so;
+
+```
+sudo pip install git+https://github.com/litex-hub/pythondata-cpu-cv32e40p.git
+```
+
+You can install a specific revision of the repository using;
+```
+pip install --user git+https://github.com/litex-hub/pythondata-cpu-cv32e40p.git@<tag>
+pip install --user git+https://github.com/litex-hub/pythondata-cpu-cv32e40p.git@<branch>
+pip install --user git+https://github.com/litex-hub/pythondata-cpu-cv32e40p.git@<hash>
+```
+
+### With `requirements.txt` file
+
+Add to your Python `requirements.txt` file using;
+```
+-e git+https://github.com/litex-hub/pythondata-cpu-cv32e40p.git
+```
+
+To use a specific revision of the repository, use the following;
+```
+-e https://github.com/litex-hub/pythondata-cpu-cv32e40p.git@<hash>
+```
+
+## Via [PyPi](https://pypi.org/project/pythondata-cpu-cv32e40p/)
+
+### Using [pip](https://pip.pypa.io/)
+
+```
+pip install --user pythondata-cpu-cv32e40p
+```
+
+### With `requirements.txt` file
+
+Add to your Python `requirements.txt` file using;
+```
+pythondata-cpu-cv32e40p
+```
+
+# Issues and Fixes
+
+This package is autogenerated from the sources in
+<https://github.com/antmicro/cv32e40p>
+using the [pythondata-auto](https://github.com/litex-hub/pythondata-auto)
+toolset. Pull requests and issues on this pythondata repo may not be monitored.
+
+
+%package help
+Summary: Development documents and examples for pythondata-cpu-cv32e40p
+Provides: python3-pythondata-cpu-cv32e40p-doc
+%description help
+# pythondata-cpu-cv32e40p
+
+Non-Python files needed for the cpu cv32e40p packaged
+into a Python module so they can be used with Python libraries and tools.
+
+This is useful for usage with tools like
+[LiteX](https://github.com/enjoy-digital/litex.git).
+
+The data files can be found under the Python module `pythondata_cpu_cv32e40p`. The
+`pythondata_cpu_cv32e40p.data_location` value can be used to find the files on the file
+system.
+
+Example of getting the data file directly;
+```python
+import pythondata_cpu_cv32e40p
+
+my_data_file = "abc.txt"
+
+with open(os.path.join(pythondata_cpu_cv32e40p.data_location, my_data_file)) as f:
+ print(f.read())
+```
+
+Example of getting the data file using `litex.data.find` API;
+```python
+from pythondata_cpu_cv32e40p import data_file
+
+my_data_file = "abc.txt"
+
+with open(data_file(my_data_file)) as f:
+ print(f.read())
+```
+
+
+The data files come from https://github.com/antmicro/cv32e40p
+and are imported using `git subtrees` to the directory
+[pythondata_cpu_cv32e40p/system_verilog](pythondata_cpu_cv32e40p/system_verilog).
+
+
+
+# Installing
+
+## Directly from git repository
+
+### Manually
+
+You can install the package manually, however this is **not** recommended.
+
+```
+git clone https://github.com/litex-hub/pythondata-cpu-cv32e40p.git
+cd pythondata-cpu-cv32e40p
+sudo python setup.py install
+```
+
+### Using [pip](https://pip.pypa.io/) with git repository
+
+You can use [pip](https://pip.pypa.io/) to install the data package directly
+from github using;
+
+```
+pip install --user git+https://github.com/litex-hub/pythondata-cpu-cv32e40p.git
+```
+
+If you want to install for the whole system rather than just the current user,
+you need to remove the `--user` argument and run as sudo like so;
+
+```
+sudo pip install git+https://github.com/litex-hub/pythondata-cpu-cv32e40p.git
+```
+
+You can install a specific revision of the repository using;
+```
+pip install --user git+https://github.com/litex-hub/pythondata-cpu-cv32e40p.git@<tag>
+pip install --user git+https://github.com/litex-hub/pythondata-cpu-cv32e40p.git@<branch>
+pip install --user git+https://github.com/litex-hub/pythondata-cpu-cv32e40p.git@<hash>
+```
+
+### With `requirements.txt` file
+
+Add to your Python `requirements.txt` file using;
+```
+-e git+https://github.com/litex-hub/pythondata-cpu-cv32e40p.git
+```
+
+To use a specific revision of the repository, use the following;
+```
+-e https://github.com/litex-hub/pythondata-cpu-cv32e40p.git@<hash>
+```
+
+## Via [PyPi](https://pypi.org/project/pythondata-cpu-cv32e40p/)
+
+### Using [pip](https://pip.pypa.io/)
+
+```
+pip install --user pythondata-cpu-cv32e40p
+```
+
+### With `requirements.txt` file
+
+Add to your Python `requirements.txt` file using;
+```
+pythondata-cpu-cv32e40p
+```
+
+# Issues and Fixes
+
+This package is autogenerated from the sources in
+<https://github.com/antmicro/cv32e40p>
+using the [pythondata-auto](https://github.com/litex-hub/pythondata-auto)
+toolset. Pull requests and issues on this pythondata repo may not be monitored.
+
+
+%prep
+%autosetup -n pythondata-cpu-cv32e40p-0.0.post152
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pythondata-cpu-cv32e40p -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.post152-1
+- Package Spec generated