summaryrefslogtreecommitdiff
path: root/python-pytricia.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pytricia.spec')
-rw-r--r--python-pytricia.spec126
1 files changed, 126 insertions, 0 deletions
diff --git a/python-pytricia.spec b/python-pytricia.spec
new file mode 100644
index 0000000..1dd52aa
--- /dev/null
+++ b/python-pytricia.spec
@@ -0,0 +1,126 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pytricia
+Version: 1.0.2
+Release: 1
+Summary: An efficient IP address storage and lookup module for Python.
+License: GNU Lesser General Public License v3 or later (LGPLv3+)
+URL: https://github.com/jsommers/pytricia
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4e/99/6d6c7cea1a4d52b8882d6a6103f4079373ae3a71d945e4e56742a5324844/pytricia-1.0.2.tar.gz
+BuildArch: noarch
+
+
+%description
+
+Pytricia is a Python module to store IP prefixes in a
+patricia tree. It's based on Dave Plonka's modified patricia tree
+code, and has three things to recommend it over related modules
+(including py-radix and SubnetTree):
+
+ * it's faster,
+
+ * it works nicely in Python 3, and
+
+ * there are a few nicer library features for manipulating the structure.
+
+See the github repo for documentation and some performance numbers: <https://github.com/jsommers/pytricia>.
+
+Pytricia is released under terms of the GNU Lesser General Public License,
+version 3.
+
+
+
+
+%package -n python3-pytricia
+Summary: An efficient IP address storage and lookup module for Python.
+Provides: python-pytricia
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pytricia
+
+Pytricia is a Python module to store IP prefixes in a
+patricia tree. It's based on Dave Plonka's modified patricia tree
+code, and has three things to recommend it over related modules
+(including py-radix and SubnetTree):
+
+ * it's faster,
+
+ * it works nicely in Python 3, and
+
+ * there are a few nicer library features for manipulating the structure.
+
+See the github repo for documentation and some performance numbers: <https://github.com/jsommers/pytricia>.
+
+Pytricia is released under terms of the GNU Lesser General Public License,
+version 3.
+
+
+
+
+%package help
+Summary: Development documents and examples for pytricia
+Provides: python3-pytricia-doc
+%description help
+
+Pytricia is a Python module to store IP prefixes in a
+patricia tree. It's based on Dave Plonka's modified patricia tree
+code, and has three things to recommend it over related modules
+(including py-radix and SubnetTree):
+
+ * it's faster,
+
+ * it works nicely in Python 3, and
+
+ * there are a few nicer library features for manipulating the structure.
+
+See the github repo for documentation and some performance numbers: <https://github.com/jsommers/pytricia>.
+
+Pytricia is released under terms of the GNU Lesser General Public License,
+version 3.
+
+
+
+
+%prep
+%autosetup -n pytricia-1.0.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pytricia -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.2-1
+- Package Spec generated