summaryrefslogtreecommitdiff
path: root/python-pytrinamic.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pytrinamic.spec')
-rw-r--r--python-pytrinamic.spec178
1 files changed, 178 insertions, 0 deletions
diff --git a/python-pytrinamic.spec b/python-pytrinamic.spec
new file mode 100644
index 0000000..c131133
--- /dev/null
+++ b/python-pytrinamic.spec
@@ -0,0 +1,178 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pytrinamic
+Version: 0.2.5
+Release: 1
+Summary: TRINAMIC's Python Technology Access Package.
+License: MIT
+URL: https://github.com/trinamic/PyTrinamic
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2c/27/8e450d2ec6d58efee118357d7efd7bc19579a296272c18c946ae557669ed/pytrinamic-0.2.5.tar.gz
+BuildArch: noarch
+
+Requires: python3-can
+Requires: python3-canopen
+Requires: python3-pyserial
+Requires: python3-IntelHex
+
+%description
+# PyTrinamic
+
+PyTrinamic is a Python package to set up and control TRINAMIC modules, evaluation boards and ICs via serial, USB or CAN interfaces.
+
+The package is intended to automate tasks that are typically done manually with TRINAMICs [TMCL-IDE](https://www.trinamic.com/support/software/tmcl-ide/).
+
+| ⚠️ Note that we changed the way PyTrinamic is used, please check out the [Migration Guide](#migration-guide)|
+|------------------------------------------------------------------------------------------------------------|
+
+## Install
+
+Use pip to install PyTrinamic.
+
+```
+pip install pytrinamic
+```
+
+## Getting Started
+
+Please have a look at the [code examples on GitHub](https://github.com/trinamic/PyTrinamic/tree/master/examples).
+
+## Migration Guide<a id="migration-guide"></a>
+
+Version 0.2.0 of PyTrinamic introduces several changes to the API. For those who want to convert code that uses an older version of PyTrinamic, we wrote a short [migration guide](https://github.com/trinamic/PyTrinamic/blob/master/docs/migration_guide.md).
+
+All previous versions of PyTrinamic will still be available on PyPI and can be installed via: `pip install pytrinamic==0.1.27`.
+
+## Contributing
+
+Pull requests are welcome. For any major changes or questions regarding implementation, please open an issue to ask or discuss first.
+
+## License
+
+PyTrinamic is licensed under the MIT License.
+
+
+%package -n python3-pytrinamic
+Summary: TRINAMIC's Python Technology Access Package.
+Provides: python-pytrinamic
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pytrinamic
+# PyTrinamic
+
+PyTrinamic is a Python package to set up and control TRINAMIC modules, evaluation boards and ICs via serial, USB or CAN interfaces.
+
+The package is intended to automate tasks that are typically done manually with TRINAMICs [TMCL-IDE](https://www.trinamic.com/support/software/tmcl-ide/).
+
+| ⚠️ Note that we changed the way PyTrinamic is used, please check out the [Migration Guide](#migration-guide)|
+|------------------------------------------------------------------------------------------------------------|
+
+## Install
+
+Use pip to install PyTrinamic.
+
+```
+pip install pytrinamic
+```
+
+## Getting Started
+
+Please have a look at the [code examples on GitHub](https://github.com/trinamic/PyTrinamic/tree/master/examples).
+
+## Migration Guide<a id="migration-guide"></a>
+
+Version 0.2.0 of PyTrinamic introduces several changes to the API. For those who want to convert code that uses an older version of PyTrinamic, we wrote a short [migration guide](https://github.com/trinamic/PyTrinamic/blob/master/docs/migration_guide.md).
+
+All previous versions of PyTrinamic will still be available on PyPI and can be installed via: `pip install pytrinamic==0.1.27`.
+
+## Contributing
+
+Pull requests are welcome. For any major changes or questions regarding implementation, please open an issue to ask or discuss first.
+
+## License
+
+PyTrinamic is licensed under the MIT License.
+
+
+%package help
+Summary: Development documents and examples for pytrinamic
+Provides: python3-pytrinamic-doc
+%description help
+# PyTrinamic
+
+PyTrinamic is a Python package to set up and control TRINAMIC modules, evaluation boards and ICs via serial, USB or CAN interfaces.
+
+The package is intended to automate tasks that are typically done manually with TRINAMICs [TMCL-IDE](https://www.trinamic.com/support/software/tmcl-ide/).
+
+| ⚠️ Note that we changed the way PyTrinamic is used, please check out the [Migration Guide](#migration-guide)|
+|------------------------------------------------------------------------------------------------------------|
+
+## Install
+
+Use pip to install PyTrinamic.
+
+```
+pip install pytrinamic
+```
+
+## Getting Started
+
+Please have a look at the [code examples on GitHub](https://github.com/trinamic/PyTrinamic/tree/master/examples).
+
+## Migration Guide<a id="migration-guide"></a>
+
+Version 0.2.0 of PyTrinamic introduces several changes to the API. For those who want to convert code that uses an older version of PyTrinamic, we wrote a short [migration guide](https://github.com/trinamic/PyTrinamic/blob/master/docs/migration_guide.md).
+
+All previous versions of PyTrinamic will still be available on PyPI and can be installed via: `pip install pytrinamic==0.1.27`.
+
+## Contributing
+
+Pull requests are welcome. For any major changes or questions regarding implementation, please open an issue to ask or discuss first.
+
+## License
+
+PyTrinamic is licensed under the MIT License.
+
+
+%prep
+%autosetup -n pytrinamic-0.2.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pytrinamic -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.5-1
+- Package Spec generated