summaryrefslogtreecommitdiff
path: root/python-pyttsx.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pyttsx.spec')
-rw-r--r--python-pyttsx.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-pyttsx.spec b/python-pyttsx.spec
new file mode 100644
index 0000000..181f662
--- /dev/null
+++ b/python-pyttsx.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyttsx
+Version: 1.1
+Release: 1
+Summary: pyttsx - cross platform text-to-speech
+License: BSD License
+URL: https://github.com/parente/pyttsx
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5b/db/45ec294a1776732b80118660ba13389f8178461273e1214d2ae604fa65a7/pyttsx-1.1.tar.gz
+BuildArch: noarch
+
+
+%description
+pyttsx is a Python package supporting common text-to-speech engines on Mac OS X, Windows, and Linux.
+
+%package -n python3-pyttsx
+Summary: pyttsx - cross platform text-to-speech
+Provides: python-pyttsx
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyttsx
+pyttsx is a Python package supporting common text-to-speech engines on Mac OS X, Windows, and Linux.
+
+%package help
+Summary: Development documents and examples for pyttsx
+Provides: python3-pyttsx-doc
+%description help
+pyttsx is a Python package supporting common text-to-speech engines on Mac OS X, Windows, and Linux.
+
+%prep
+%autosetup -n pyttsx-1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyttsx -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1-1
+- Package Spec generated