summaryrefslogtreecommitdiff
path: root/python-pytutils.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pytutils.spec')
-rw-r--r--python-pytutils.spec87
1 files changed, 87 insertions, 0 deletions
diff --git a/python-pytutils.spec b/python-pytutils.spec
new file mode 100644
index 0000000..63df8c5
--- /dev/null
+++ b/python-pytutils.spec
@@ -0,0 +1,87 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pytutils
+Version: 0.4.1
+Release: 1
+Summary: Heap of garbage from trevorj
+License: GPL
+URL: https://github.com/akatrevorjay/pytutils
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a8/2e/ab370a836425c4eb9543b4a2e39140452f637b5403d57c42e6461ae18a66/pytutils-0.4.1.tar.gz
+BuildArch: noarch
+
+
+%description
+Common utilities.
+New portions are py3 only, but most is currently still 2.7.x compat.
+|ci-badge| |coverage-badge| |docs-badge|
+- Docs: http://pytutils.readthedocs.org/en/latest
+- API Docs: http://pytutils.readthedocs.org/en/latest/pytutils.html
+- PyPi: https://pypi.python.org/pypi/pytutils
+
+%package -n python3-pytutils
+Summary: Heap of garbage from trevorj
+Provides: python-pytutils
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pytutils
+Common utilities.
+New portions are py3 only, but most is currently still 2.7.x compat.
+|ci-badge| |coverage-badge| |docs-badge|
+- Docs: http://pytutils.readthedocs.org/en/latest
+- API Docs: http://pytutils.readthedocs.org/en/latest/pytutils.html
+- PyPi: https://pypi.python.org/pypi/pytutils
+
+%package help
+Summary: Development documents and examples for pytutils
+Provides: python3-pytutils-doc
+%description help
+Common utilities.
+New portions are py3 only, but most is currently still 2.7.x compat.
+|ci-badge| |coverage-badge| |docs-badge|
+- Docs: http://pytutils.readthedocs.org/en/latest
+- API Docs: http://pytutils.readthedocs.org/en/latest/pytutils.html
+- PyPi: https://pypi.python.org/pypi/pytutils
+
+%prep
+%autosetup -n pytutils-0.4.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pytutils -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.1-1
+- Package Spec generated