summaryrefslogtreecommitdiff
path: root/python-pytweening.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 12:26:48 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 12:26:48 +0000
commit93761bea666f2f12ff497f2396d57b727481d677 (patch)
tree4d3633f6fef2861be6e8e257dc59d019f32f5c2a /python-pytweening.spec
parentaf16388c48b2d5d2e22a8fc9ea288f9dc5f86560 (diff)
automatic import of python-pytweening
Diffstat (limited to 'python-pytweening.spec')
-rw-r--r--python-pytweening.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-pytweening.spec b/python-pytweening.spec
new file mode 100644
index 0000000..1d9b7c2
--- /dev/null
+++ b/python-pytweening.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pytweening
+Version: 1.0.4
+Release: 1
+Summary: A collection of tweening / easing functions.
+License: MIT
+URL: https://github.com/asweigart/pytweening
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e9/4f/acb6a2d95260a4377885e40c167fd5df587630696a6a7934675f86aebb06/pytweening-1.0.4.tar.gz
+BuildArch: noarch
+
+
+%description
+A collection of tweening / easing functions implemented in Python.
+
+%package -n python3-pytweening
+Summary: A collection of tweening / easing functions.
+Provides: python-pytweening
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pytweening
+A collection of tweening / easing functions implemented in Python.
+
+%package help
+Summary: Development documents and examples for pytweening
+Provides: python3-pytweening-doc
+%description help
+A collection of tweening / easing functions implemented in Python.
+
+%prep
+%autosetup -n pytweening-1.0.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pytweening -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.4-1
+- Package Spec generated