summaryrefslogtreecommitdiff
path: root/python-pyutilib-component-core.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pyutilib-component-core.spec')
-rw-r--r--python-pyutilib-component-core.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-pyutilib-component-core.spec b/python-pyutilib-component-core.spec
new file mode 100644
index 0000000..edbf1d5
--- /dev/null
+++ b/python-pyutilib-component-core.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyutilib.component.core
+Version: 4.6.4
+Release: 1
+Summary: The PyUtilib Component Architecture.
+License: BSD
+URL: https://software.sandia.gov/svn/public/pyutilib/pyutilib.component.core
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3e/98/4a54ea39806da1e89031624743fc5912f9b4e40509963ed668382ce26712/pyutilib.component.core-4.6.4.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-pyutilib.component.core
+Summary: The PyUtilib Component Architecture.
+Provides: python-pyutilib.component.core
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyutilib.component.core
+
+
+%package help
+Summary: Development documents and examples for pyutilib.component.core
+Provides: python3-pyutilib.component.core-doc
+%description help
+
+
+%prep
+%autosetup -n pyutilib.component.core-4.6.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyutilib.component.core -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 4.6.4-1
+- Package Spec generated