summaryrefslogtreecommitdiff
path: root/python-pyvera.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pyvera.spec')
-rw-r--r--python-pyvera.spec109
1 files changed, 109 insertions, 0 deletions
diff --git a/python-pyvera.spec b/python-pyvera.spec
new file mode 100644
index 0000000..ca1ffaf
--- /dev/null
+++ b/python-pyvera.spec
@@ -0,0 +1,109 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyvera
+Version: 0.3.15
+Release: 1
+Summary: Python API for talking to Veracontrollers
+License: GPL2
+URL: https://github.com/pavoni/pyvera
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2d/91/a1e7a818a9ea84f3c0159c7173afc40485509aa7cf790ca61119356ab76d/pyvera-0.3.15.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+
+%description
+ >>> import pyvera
+ >>> controller = pyvera.VeraController("http://192.168.1.161:3480/")
+ >>> devices = controller.get_devices('On/Off Switch')
+ >>> devices
+ [VeraSwitch (id=15 category=On/Off Switch name=Bookcase Uplighters), VeraSwitch (id=16 category=On/Off Switch name=Bookcase device)]
+ >>> devices[1]
+ VeraSwitch (id=15 category=On/Off Switch name=Bookcase Uplighters)
+ >>> devices[1].is_switched_on()
+ False
+ >>> devices[1].switch_on()
+ >>> devices[1].is_switched_on()
+ True
+ >>> devices[1].switch_off()
+
+%package -n python3-pyvera
+Summary: Python API for talking to Veracontrollers
+Provides: python-pyvera
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyvera
+ >>> import pyvera
+ >>> controller = pyvera.VeraController("http://192.168.1.161:3480/")
+ >>> devices = controller.get_devices('On/Off Switch')
+ >>> devices
+ [VeraSwitch (id=15 category=On/Off Switch name=Bookcase Uplighters), VeraSwitch (id=16 category=On/Off Switch name=Bookcase device)]
+ >>> devices[1]
+ VeraSwitch (id=15 category=On/Off Switch name=Bookcase Uplighters)
+ >>> devices[1].is_switched_on()
+ False
+ >>> devices[1].switch_on()
+ >>> devices[1].is_switched_on()
+ True
+ >>> devices[1].switch_off()
+
+%package help
+Summary: Development documents and examples for pyvera
+Provides: python3-pyvera-doc
+%description help
+ >>> import pyvera
+ >>> controller = pyvera.VeraController("http://192.168.1.161:3480/")
+ >>> devices = controller.get_devices('On/Off Switch')
+ >>> devices
+ [VeraSwitch (id=15 category=On/Off Switch name=Bookcase Uplighters), VeraSwitch (id=16 category=On/Off Switch name=Bookcase device)]
+ >>> devices[1]
+ VeraSwitch (id=15 category=On/Off Switch name=Bookcase Uplighters)
+ >>> devices[1].is_switched_on()
+ False
+ >>> devices[1].switch_on()
+ >>> devices[1].is_switched_on()
+ True
+ >>> devices[1].switch_off()
+
+%prep
+%autosetup -n pyvera-0.3.15
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyvera -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.15-1
+- Package Spec generated