summaryrefslogtreecommitdiff
path: root/python-pywilight.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pywilight.spec')
-rw-r--r--python-pywilight.spec125
1 files changed, 125 insertions, 0 deletions
diff --git a/python-pywilight.spec b/python-pywilight.spec
new file mode 100644
index 0000000..50107df
--- /dev/null
+++ b/python-pywilight.spec
@@ -0,0 +1,125 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pywilight
+Version: 0.0.74
+Release: 1
+Summary: Python API for WiLight in Home Assistant
+License: MIT License
+URL: https://github.com/leofig-rj/pywilight
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5d/9b/21cb48ba5b1762002bf05efe57ade725b212e2d337933fb0bac3d29694d9/pywilight-0.0.74.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+Requires: python3-ifaddr
+
+%description
+# Python API for WiLight devices in Home Assistant
+
+A simple Python API for controlling devices from [WiLight](https://www.wilight.com.br), developed for integration with Home Assistant. At present, the following devices are currently supported:
+
+- I-100
+- I-102
+- C-103
+- V-104
+- R-105
+- I-107
+- I-110
+
+TCP client with some ideas of [hlk-sw16](https://github.com/jameshilliard/hlk-sw16).
+Discovery based on [pywemo](https://github.com/pavoni/pywemo).
+Thanks to the contributors.
+
+
+
+
+%package -n python3-pywilight
+Summary: Python API for WiLight in Home Assistant
+Provides: python-pywilight
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pywilight
+# Python API for WiLight devices in Home Assistant
+
+A simple Python API for controlling devices from [WiLight](https://www.wilight.com.br), developed for integration with Home Assistant. At present, the following devices are currently supported:
+
+- I-100
+- I-102
+- C-103
+- V-104
+- R-105
+- I-107
+- I-110
+
+TCP client with some ideas of [hlk-sw16](https://github.com/jameshilliard/hlk-sw16).
+Discovery based on [pywemo](https://github.com/pavoni/pywemo).
+Thanks to the contributors.
+
+
+
+
+%package help
+Summary: Development documents and examples for pywilight
+Provides: python3-pywilight-doc
+%description help
+# Python API for WiLight devices in Home Assistant
+
+A simple Python API for controlling devices from [WiLight](https://www.wilight.com.br), developed for integration with Home Assistant. At present, the following devices are currently supported:
+
+- I-100
+- I-102
+- C-103
+- V-104
+- R-105
+- I-107
+- I-110
+
+TCP client with some ideas of [hlk-sw16](https://github.com/jameshilliard/hlk-sw16).
+Discovery based on [pywemo](https://github.com/pavoni/pywemo).
+Thanks to the contributors.
+
+
+
+
+%prep
+%autosetup -n pywilight-0.0.74
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pywilight -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.74-1
+- Package Spec generated