summaryrefslogtreecommitdiff
path: root/python-pyzipper.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pyzipper.spec')
-rw-r--r--python-pyzipper.spec82
1 files changed, 82 insertions, 0 deletions
diff --git a/python-pyzipper.spec b/python-pyzipper.spec
new file mode 100644
index 0000000..f8dac85
--- /dev/null
+++ b/python-pyzipper.spec
@@ -0,0 +1,82 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyzipper
+Version: 0.3.6
+Release: 1
+Summary: AES encryption for zipfile.
+License: MIT
+URL: https://github.com/danifus/pyzipper
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ac/97/2f03c67b40e531b30f0e1357476b4db989097a92cd30c6d2389cfa12db49/pyzipper-0.3.6.tar.gz
+BuildArch: noarch
+
+Requires: python3-pycryptodomex
+
+%description
+A replacement for Python's ``zipfile`` that can read and write AES encrypted
+zip files. Forked from Python 3.7's ``zipfile`` module, it features the same
+``zipfile`` API from that time (most notably, lacking support for
+``pathlib``-compatible wrappers that were introduced in Python 3.8).
+
+%package -n python3-pyzipper
+Summary: AES encryption for zipfile.
+Provides: python-pyzipper
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyzipper
+A replacement for Python's ``zipfile`` that can read and write AES encrypted
+zip files. Forked from Python 3.7's ``zipfile`` module, it features the same
+``zipfile`` API from that time (most notably, lacking support for
+``pathlib``-compatible wrappers that were introduced in Python 3.8).
+
+%package help
+Summary: Development documents and examples for pyzipper
+Provides: python3-pyzipper-doc
+%description help
+A replacement for Python's ``zipfile`` that can read and write AES encrypted
+zip files. Forked from Python 3.7's ``zipfile`` module, it features the same
+``zipfile`` API from that time (most notably, lacking support for
+``pathlib``-compatible wrappers that were introduced in Python 3.8).
+
+%prep
+%autosetup -n pyzipper-0.3.6
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyzipper -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.6-1
+- Package Spec generated