summaryrefslogtreecommitdiff
path: root/python-quantarhei.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-quantarhei.spec')
-rw-r--r--python-quantarhei.spec87
1 files changed, 87 insertions, 0 deletions
diff --git a/python-quantarhei.spec b/python-quantarhei.spec
new file mode 100644
index 0000000..c069587
--- /dev/null
+++ b/python-quantarhei.spec
@@ -0,0 +1,87 @@
+%global _empty_manifest_terminate_build 0
+Name: python-quantarhei
+Version: 0.0.65
+Release: 1
+Summary: Quantarhei: Open Quantum System Theory for Molecular Systems
+License: MIT
+URL: https://github.com/tmancal74/quantarhei
+Source0: https://mirrors.aliyun.com/pypi/web/packages/cd/03/cd6fd178852685d0b0a5b274a27585b3ee6a02d36381f9e9bae6100af21f/quantarhei-0.0.65.tar.gz
+BuildArch: noarch
+
+
+%description
+Quantarhei is a Molecular Open Quantum Systems Simulator written predominantly
+in Python. Its name is derived from the famous aphorism "Panta rhei" of the
+Greek philosopher Heraclitus of Ephesus. "Panta rhei" means "Everything flows"
+or "Everything is in flux" which is quite fitting when you change Panta into
+Quanta.
+In "Quantarhei" the last four letters ("rhei") should be written in Greek,
+
+%package -n python3-quantarhei
+Summary: Quantarhei: Open Quantum System Theory for Molecular Systems
+Provides: python-quantarhei
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-quantarhei
+Quantarhei is a Molecular Open Quantum Systems Simulator written predominantly
+in Python. Its name is derived from the famous aphorism "Panta rhei" of the
+Greek philosopher Heraclitus of Ephesus. "Panta rhei" means "Everything flows"
+or "Everything is in flux" which is quite fitting when you change Panta into
+Quanta.
+In "Quantarhei" the last four letters ("rhei") should be written in Greek,
+
+%package help
+Summary: Development documents and examples for quantarhei
+Provides: python3-quantarhei-doc
+%description help
+Quantarhei is a Molecular Open Quantum Systems Simulator written predominantly
+in Python. Its name is derived from the famous aphorism "Panta rhei" of the
+Greek philosopher Heraclitus of Ephesus. "Panta rhei" means "Everything flows"
+or "Everything is in flux" which is quite fitting when you change Panta into
+Quanta.
+In "Quantarhei" the last four letters ("rhei") should be written in Greek,
+
+%prep
+%autosetup -n quantarhei-0.0.65
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-quantarhei -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.65-1
+- Package Spec generated