summaryrefslogtreecommitdiff
path: root/python-quart-openapi.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-quart-openapi.spec')
-rw-r--r--python-quart-openapi.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-quart-openapi.spec b/python-quart-openapi.spec
new file mode 100644
index 0000000..8478a2d
--- /dev/null
+++ b/python-quart-openapi.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-quart-openapi
+Version: 1.7.2
+Release: 1
+Summary: Framework for Quart to add swagger generation to routes and restful resources
+License: Apache 2.0
+URL: https://github.com/factset/quart-openapi
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3c/48/973b0dbddaf4cde9a4207340e8e3f2536ecbc513fc4439a2819f69a859ad/quart-openapi-1.7.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-jsonschema
+Requires: python3-werkzeug
+Requires: python3-quart
+Requires: python3-Sphinx
+Requires: python3-sphinx-autodoc-typehints
+Requires: python3-alabaster
+
+%description
+
+
+%package -n python3-quart-openapi
+Summary: Framework for Quart to add swagger generation to routes and restful resources
+Provides: python-quart-openapi
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-quart-openapi
+
+
+%package help
+Summary: Development documents and examples for quart-openapi
+Provides: python3-quart-openapi-doc
+%description help
+
+
+%prep
+%autosetup -n quart-openapi-1.7.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-quart-openapi -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.7.2-1
+- Package Spec generated