summaryrefslogtreecommitdiff
path: root/python-r7insight-python.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-r7insight-python.spec')
-rw-r--r--python-r7insight-python.spec85
1 files changed, 85 insertions, 0 deletions
diff --git a/python-r7insight-python.spec b/python-r7insight-python.spec
new file mode 100644
index 0000000..0fbb8c3
--- /dev/null
+++ b/python-r7insight-python.spec
@@ -0,0 +1,85 @@
+%global _empty_manifest_terminate_build 0
+Name: python-r7insight-python
+Version: 1.0.0
+Release: 1
+Summary: Python Logger plugin to send logs to Rapid7 Insight
+License: LICENSE.txt
+URL: http://pypi.python.org/pypi/R7Insight/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/77/ed/b3a4f2c8e16717f0d97ca92709b0d39de0f94bec36a58dbca6d87afcec78/r7insight_python-1.0.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-certifi
+
+%description
+This is a plugin library to enable logging to Rapid7 Insight from the Python Logger.
+Additionally this plugin allows the user to get an overview of methods being executed,
+their execution time, as well as CPU and Memory statistics.
+More info at https://www.rapid7.com/solutions/it-operations/. Note that this plugin is
+**asynchronous**.
+
+%package -n python3-r7insight-python
+Summary: Python Logger plugin to send logs to Rapid7 Insight
+Provides: python-r7insight-python
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-r7insight-python
+This is a plugin library to enable logging to Rapid7 Insight from the Python Logger.
+Additionally this plugin allows the user to get an overview of methods being executed,
+their execution time, as well as CPU and Memory statistics.
+More info at https://www.rapid7.com/solutions/it-operations/. Note that this plugin is
+**asynchronous**.
+
+%package help
+Summary: Development documents and examples for r7insight-python
+Provides: python3-r7insight-python-doc
+%description help
+This is a plugin library to enable logging to Rapid7 Insight from the Python Logger.
+Additionally this plugin allows the user to get an overview of methods being executed,
+their execution time, as well as CPU and Memory statistics.
+More info at https://www.rapid7.com/solutions/it-operations/. Note that this plugin is
+**asynchronous**.
+
+%prep
+%autosetup -n r7insight-python-1.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-r7insight-python -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
+- Package Spec generated