summaryrefslogtreecommitdiff
path: root/python-redpatch.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-redpatch.spec')
-rw-r--r--python-redpatch.spec85
1 files changed, 85 insertions, 0 deletions
diff --git a/python-redpatch.spec b/python-redpatch.spec
new file mode 100644
index 0000000..ced64c2
--- /dev/null
+++ b/python-redpatch.spec
@@ -0,0 +1,85 @@
+%global _empty_manifest_terminate_build 0
+Name: python-redpatch
+Version: 0.2.4
+Release: 1
+Summary: Finding Disease Lesions in Plant Leaves
+License: LICENSE.txt
+URL: https://github.com/TeamMacLean/redpatch
+Source0: https://mirrors.aliyun.com/pypi/web/packages/98/7f/23ebe2da927fe166d02f46310ef8e8b9fe1ea28bf34fe5313ba485da8119/redpatch-0.2.4.tar.gz
+BuildArch: noarch
+
+Requires: python3-ipywidgets
+Requires: python3-ipython
+Requires: python3-jupyter
+Requires: python3-numpy
+Requires: python3-numba
+Requires: python3-matplotlib
+Requires: python3-pytest
+Requires: python3-scikit-image
+Requires: python3-scipy
+Requires: python3-pyyaml
+Requires: python3-shapely
+Requires: python3-pandas
+Requires: python3-yattag
+
+%description
+
+
+%package -n python3-redpatch
+Summary: Finding Disease Lesions in Plant Leaves
+Provides: python-redpatch
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-redpatch
+
+
+%package help
+Summary: Development documents and examples for redpatch
+Provides: python3-redpatch-doc
+%description help
+
+
+%prep
+%autosetup -n redpatch-0.2.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-redpatch -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.4-1
+- Package Spec generated