summaryrefslogtreecommitdiff
path: root/python-redssh.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-redssh.spec')
-rw-r--r--python-redssh.spec210
1 files changed, 210 insertions, 0 deletions
diff --git a/python-redssh.spec b/python-redssh.spec
new file mode 100644
index 0000000..b702899
--- /dev/null
+++ b/python-redssh.spec
@@ -0,0 +1,210 @@
+%global _empty_manifest_terminate_build 0
+Name: python-redssh
+Version: 3.0.1
+Release: 1
+Summary: An SSH automation library.
+License: GPLv2
+URL: https://bitbucket.org/Red_M/RedSSH
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3a/79/e8efebb811196e4e2a8b39836fc93b91dbf9f5e41d2023981aa26a8ce8c4/redssh-3.0.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-redlibssh2
+Requires: python3-redlibssh
+Requires: python3-sphinx
+Requires: python3-redlibssh
+Requires: python3-sphinx-rtd-theme
+Requires: python3-redlibssh2
+Requires: python3-redlibssh
+Requires: python3-coveralls
+Requires: python3-redlibssh2
+Requires: python3-pylint
+Requires: python3-pytest-cov
+Requires: python3-safety
+Requires: python3-bandit
+Requires: python3-requests[socks]
+Requires: python3-jinja2
+
+%description
+# RedSSH
+![PyPI](https://img.shields.io/pypi/v/RedSSH?style=plastic)
+[![License: GPL v2](https://img.shields.io/badge/License-GPL%20v2-blue.svg?style=plastic)](https://www.gnu.org/licenses/old-licenses/gpl-2.0.en.html)
+
+[![Test Status](https://travis-ci.com/Red-M/RedSSH.svg?branch=master)](https://travis-ci.com/Red-M/RedSSH)
+[![Documentation Status](https://readthedocs.org/projects/redssh/badge/?version=latest)](https://redssh.readthedocs.io/en/latest/?badge=latest)
+[![Coverage Status](https://coveralls.io/repos/github/Red-M/RedSSH/badge.svg?branch=master)](https://coveralls.io/github/Red-M/RedSSH?branch=master)
+
+Connect to SSH servers in python easily and with C speed!
+Interacting with SSH shouldn't be hard, slow or limited to certain SSH severs.
+Based on ssh2-python (which provides libssh2 bindings for python) and made into an easy to use SSH library with the focus being ease of use and speed.
+SSH should be as easy as a pre-wrapped TLS TCP socket, it should work well, be fast in execution and be simple to interact with.
+
+
+# Installing
+
+RedSSH can be installed via pip with `pip install redssh` or the latest commit, which may not be the most stable, from git with `pip install git://git@bitbucket.org/Red_M/redssh.git`
+
+
+# Documentation
+99% of questions around how to do something should be answered in the documentation.
+If something is not there please raise an issue so it can be added to the documentation.
+[Now with autodocs!](https://redssh.readthedocs.io/en/latest/ "Documentation! :)")
+
+
+# Why not use [other software]?
+
+I've found other automation libraries or solutions lacking, such as:
+- Compatibility with remote servers (odd servers causes the library to be unable to connect).
+- Feature set is limited (eg, no tunneling).
+- Focuses on only connecting to Linux servers.
+- Requires an agent to be installed, a state file to be present or a master "server".
+- Poor performance.
+
+
+# TO DO
+- More error based unit tests
+- More examples
+- Host based authentication
+- X11 forwarding
+
+
+
+%package -n python3-redssh
+Summary: An SSH automation library.
+Provides: python-redssh
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-redssh
+# RedSSH
+![PyPI](https://img.shields.io/pypi/v/RedSSH?style=plastic)
+[![License: GPL v2](https://img.shields.io/badge/License-GPL%20v2-blue.svg?style=plastic)](https://www.gnu.org/licenses/old-licenses/gpl-2.0.en.html)
+
+[![Test Status](https://travis-ci.com/Red-M/RedSSH.svg?branch=master)](https://travis-ci.com/Red-M/RedSSH)
+[![Documentation Status](https://readthedocs.org/projects/redssh/badge/?version=latest)](https://redssh.readthedocs.io/en/latest/?badge=latest)
+[![Coverage Status](https://coveralls.io/repos/github/Red-M/RedSSH/badge.svg?branch=master)](https://coveralls.io/github/Red-M/RedSSH?branch=master)
+
+Connect to SSH servers in python easily and with C speed!
+Interacting with SSH shouldn't be hard, slow or limited to certain SSH severs.
+Based on ssh2-python (which provides libssh2 bindings for python) and made into an easy to use SSH library with the focus being ease of use and speed.
+SSH should be as easy as a pre-wrapped TLS TCP socket, it should work well, be fast in execution and be simple to interact with.
+
+
+# Installing
+
+RedSSH can be installed via pip with `pip install redssh` or the latest commit, which may not be the most stable, from git with `pip install git://git@bitbucket.org/Red_M/redssh.git`
+
+
+# Documentation
+99% of questions around how to do something should be answered in the documentation.
+If something is not there please raise an issue so it can be added to the documentation.
+[Now with autodocs!](https://redssh.readthedocs.io/en/latest/ "Documentation! :)")
+
+
+# Why not use [other software]?
+
+I've found other automation libraries or solutions lacking, such as:
+- Compatibility with remote servers (odd servers causes the library to be unable to connect).
+- Feature set is limited (eg, no tunneling).
+- Focuses on only connecting to Linux servers.
+- Requires an agent to be installed, a state file to be present or a master "server".
+- Poor performance.
+
+
+# TO DO
+- More error based unit tests
+- More examples
+- Host based authentication
+- X11 forwarding
+
+
+
+%package help
+Summary: Development documents and examples for redssh
+Provides: python3-redssh-doc
+%description help
+# RedSSH
+![PyPI](https://img.shields.io/pypi/v/RedSSH?style=plastic)
+[![License: GPL v2](https://img.shields.io/badge/License-GPL%20v2-blue.svg?style=plastic)](https://www.gnu.org/licenses/old-licenses/gpl-2.0.en.html)
+
+[![Test Status](https://travis-ci.com/Red-M/RedSSH.svg?branch=master)](https://travis-ci.com/Red-M/RedSSH)
+[![Documentation Status](https://readthedocs.org/projects/redssh/badge/?version=latest)](https://redssh.readthedocs.io/en/latest/?badge=latest)
+[![Coverage Status](https://coveralls.io/repos/github/Red-M/RedSSH/badge.svg?branch=master)](https://coveralls.io/github/Red-M/RedSSH?branch=master)
+
+Connect to SSH servers in python easily and with C speed!
+Interacting with SSH shouldn't be hard, slow or limited to certain SSH severs.
+Based on ssh2-python (which provides libssh2 bindings for python) and made into an easy to use SSH library with the focus being ease of use and speed.
+SSH should be as easy as a pre-wrapped TLS TCP socket, it should work well, be fast in execution and be simple to interact with.
+
+
+# Installing
+
+RedSSH can be installed via pip with `pip install redssh` or the latest commit, which may not be the most stable, from git with `pip install git://git@bitbucket.org/Red_M/redssh.git`
+
+
+# Documentation
+99% of questions around how to do something should be answered in the documentation.
+If something is not there please raise an issue so it can be added to the documentation.
+[Now with autodocs!](https://redssh.readthedocs.io/en/latest/ "Documentation! :)")
+
+
+# Why not use [other software]?
+
+I've found other automation libraries or solutions lacking, such as:
+- Compatibility with remote servers (odd servers causes the library to be unable to connect).
+- Feature set is limited (eg, no tunneling).
+- Focuses on only connecting to Linux servers.
+- Requires an agent to be installed, a state file to be present or a master "server".
+- Poor performance.
+
+
+# TO DO
+- More error based unit tests
+- More examples
+- Host based authentication
+- X11 forwarding
+
+
+
+%prep
+%autosetup -n redssh-3.0.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-redssh -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 3.0.1-1
+- Package Spec generated