summaryrefslogtreecommitdiff
path: root/python-reedsolo.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 11:41:35 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 11:41:35 +0000
commitd8d468f8e95fa43421ce49cba55ed25cc248c3b9 (patch)
treeb303640983e60146aee30a2c2ebcae237a1d7dec /python-reedsolo.spec
parentbd446c55ed60382e4981ea44765f52497a3cf4c9 (diff)
automatic import of python-reedsolo
Diffstat (limited to 'python-reedsolo.spec')
-rw-r--r--python-reedsolo.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-reedsolo.spec b/python-reedsolo.spec
new file mode 100644
index 0000000..3cb7e71
--- /dev/null
+++ b/python-reedsolo.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-reedsolo
+Version: 1.7.0
+Release: 1
+Summary: Pure-Python Reed Solomon encoder/decoder
+License: Public Domain
+URL: https://github.com/tomerfiliba/reedsolomon
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f7/61/a67338cbecf370d464e71b10e9a31355f909d6937c3a8d6b17dd5d5beb5e/reedsolo-1.7.0.tar.gz
+BuildArch: noarch
+
+
+%description
+|PyPI-Status| |PyPI-Versions| |PyPI-Downloads|
+|Build-Status| |Coverage|
+|Conda-Forge-Status| |Conda-Forge-Platforms| |Conda-Forge-Downloads|
+A pythonic `universal errors-and-erasures Reed-Solomon Codec <http://en.wikipedia.org/wiki/Reed%E2%80%93Solomon_error_correction>`_ to protect your data from errors and bitrot. It includes a pure python implementation and an optional speed-optimized Cython/C extension.
+This is a burst-type implementation, so that it supports any Galois field higher than 2^3, but not binary streams. Burst errors are non-random errors that more often happen on data storage mediums such as hard drives, hence this library is better suited for data storage protection, and less for streams noise correction, although it also works for this purpose but with a bit of overhead (since it works with bytes only, instead of bits).
+
+%package -n python3-reedsolo
+Summary: Pure-Python Reed Solomon encoder/decoder
+Provides: python-reedsolo
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-reedsolo
+|PyPI-Status| |PyPI-Versions| |PyPI-Downloads|
+|Build-Status| |Coverage|
+|Conda-Forge-Status| |Conda-Forge-Platforms| |Conda-Forge-Downloads|
+A pythonic `universal errors-and-erasures Reed-Solomon Codec <http://en.wikipedia.org/wiki/Reed%E2%80%93Solomon_error_correction>`_ to protect your data from errors and bitrot. It includes a pure python implementation and an optional speed-optimized Cython/C extension.
+This is a burst-type implementation, so that it supports any Galois field higher than 2^3, but not binary streams. Burst errors are non-random errors that more often happen on data storage mediums such as hard drives, hence this library is better suited for data storage protection, and less for streams noise correction, although it also works for this purpose but with a bit of overhead (since it works with bytes only, instead of bits).
+
+%package help
+Summary: Development documents and examples for reedsolo
+Provides: python3-reedsolo-doc
+%description help
+|PyPI-Status| |PyPI-Versions| |PyPI-Downloads|
+|Build-Status| |Coverage|
+|Conda-Forge-Status| |Conda-Forge-Platforms| |Conda-Forge-Downloads|
+A pythonic `universal errors-and-erasures Reed-Solomon Codec <http://en.wikipedia.org/wiki/Reed%E2%80%93Solomon_error_correction>`_ to protect your data from errors and bitrot. It includes a pure python implementation and an optional speed-optimized Cython/C extension.
+This is a burst-type implementation, so that it supports any Galois field higher than 2^3, but not binary streams. Burst errors are non-random errors that more often happen on data storage mediums such as hard drives, hence this library is better suited for data storage protection, and less for streams noise correction, although it also works for this purpose but with a bit of overhead (since it works with bytes only, instead of bits).
+
+%prep
+%autosetup -n reedsolo-1.7.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-reedsolo -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.7.0-1
+- Package Spec generated