summaryrefslogtreecommitdiff
path: root/python-renovosolutions-aws-cdk-aspects-security-group.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-renovosolutions-aws-cdk-aspects-security-group.spec')
-rw-r--r--python-renovosolutions-aws-cdk-aspects-security-group.spec221
1 files changed, 221 insertions, 0 deletions
diff --git a/python-renovosolutions-aws-cdk-aspects-security-group.spec b/python-renovosolutions-aws-cdk-aspects-security-group.spec
new file mode 100644
index 0000000..8ce038e
--- /dev/null
+++ b/python-renovosolutions-aws-cdk-aspects-security-group.spec
@@ -0,0 +1,221 @@
+%global _empty_manifest_terminate_build 0
+Name: python-renovosolutions.aws-cdk-aspects-security-group
+Version: 2.1.100
+Release: 1
+Summary: A library of CDK aspects applying to security groups.
+License: Apache-2.0
+URL: https://github.com/RenovoSolutions/cdk-aspects-library-security-group.git
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/75/54/c8980b9f724b4314bca77dea135c85bce347a81a0520f0ca27604288cfb8/renovosolutions.aws-cdk-aspects-security-group-2.1.100.tar.gz
+BuildArch: noarch
+
+Requires: python3-aws-cdk-lib
+Requires: python3-constructs
+Requires: python3-jsii
+Requires: python3-publication
+Requires: python3-typeguard
+
+%description
+# cdk-aspects-library-security-group
+
+[![build](https://github.com/RenovoSolutions/cdk-aspects-library-security-group/actions/workflows/build.yml/badge.svg)](https://github.com/RenovoSolutions/cdk-aspects-library-security-group/actions/workflows/build.yml)
+
+A CDK library containing EC2 security group related [CDK Aspects](https://docs.aws.amazon.com/cdk/latest/guide/aspects.html) and the ability to define custom aspects.
+
+## Features
+
+* Utilize built in aspects for common cases:
+
+ * Disallow public access to any port
+ * Disallow public access to AWS Restricted Common ports ([per the AWS Config rule](https://docs.aws.amazon.com/config/latest/developerguide/restricted-common-ports.html))
+ * Disallow public access to SSH or RDP per CIS Benchmark guidelines and general good practice
+ * Disallow public or ALL access to common management ports like SSH, RDP, WinRM, WinRM over HTTPS
+ * Disallow public or ALL access common relational DB ports like MSSQL, MySQL, PostgreSQL, and Oracle
+ * Disallow public or ALL common web ports like HTTP (80, 8080) and HTTPS (443, 8443)
+* Create any other aspect using the base security group aspect class.
+* By default aspects generate errors in the CDK metadata which the deployment or synth process will find, but this can be changed with the `annotationType` property
+* All default provided aspects restrict based on the public access CIDRs (`0.0.0.0/0` and `::/0`) but you can also defined aspects with any set of restricted CIDRs or security group IDs you like
+
+## API Doc
+
+See [API](API.md)
+
+## Examples
+
+### Typescript
+
+```
+// Add an existing aspect to your stack
+Aspects.of(stack).add(new NoPublicIngressAspect());
+
+// Add a custom aspect to your stack
+Aspects.of(stack).add(new SecurityGroupAspectBase({
+ annotationText: 'This is a custom message warning you how you should not do what you are doing.',
+ annotationType: AnnotationType.WARNING,
+ ports: [5985],
+ restrictedCidrs: ['10.1.0.0/16'],
+}));
+
+// Change an existing aspects message and type
+Aspects.of(stack).add(new NoPublicIngressAspect(
+ annotationText: 'This is custom text.',
+ annotationType: AnnotationType.WARNING
+));
+```
+
+
+
+
+%package -n python3-renovosolutions.aws-cdk-aspects-security-group
+Summary: A library of CDK aspects applying to security groups.
+Provides: python-renovosolutions.aws-cdk-aspects-security-group
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-renovosolutions.aws-cdk-aspects-security-group
+# cdk-aspects-library-security-group
+
+[![build](https://github.com/RenovoSolutions/cdk-aspects-library-security-group/actions/workflows/build.yml/badge.svg)](https://github.com/RenovoSolutions/cdk-aspects-library-security-group/actions/workflows/build.yml)
+
+A CDK library containing EC2 security group related [CDK Aspects](https://docs.aws.amazon.com/cdk/latest/guide/aspects.html) and the ability to define custom aspects.
+
+## Features
+
+* Utilize built in aspects for common cases:
+
+ * Disallow public access to any port
+ * Disallow public access to AWS Restricted Common ports ([per the AWS Config rule](https://docs.aws.amazon.com/config/latest/developerguide/restricted-common-ports.html))
+ * Disallow public access to SSH or RDP per CIS Benchmark guidelines and general good practice
+ * Disallow public or ALL access to common management ports like SSH, RDP, WinRM, WinRM over HTTPS
+ * Disallow public or ALL access common relational DB ports like MSSQL, MySQL, PostgreSQL, and Oracle
+ * Disallow public or ALL common web ports like HTTP (80, 8080) and HTTPS (443, 8443)
+* Create any other aspect using the base security group aspect class.
+* By default aspects generate errors in the CDK metadata which the deployment or synth process will find, but this can be changed with the `annotationType` property
+* All default provided aspects restrict based on the public access CIDRs (`0.0.0.0/0` and `::/0`) but you can also defined aspects with any set of restricted CIDRs or security group IDs you like
+
+## API Doc
+
+See [API](API.md)
+
+## Examples
+
+### Typescript
+
+```
+// Add an existing aspect to your stack
+Aspects.of(stack).add(new NoPublicIngressAspect());
+
+// Add a custom aspect to your stack
+Aspects.of(stack).add(new SecurityGroupAspectBase({
+ annotationText: 'This is a custom message warning you how you should not do what you are doing.',
+ annotationType: AnnotationType.WARNING,
+ ports: [5985],
+ restrictedCidrs: ['10.1.0.0/16'],
+}));
+
+// Change an existing aspects message and type
+Aspects.of(stack).add(new NoPublicIngressAspect(
+ annotationText: 'This is custom text.',
+ annotationType: AnnotationType.WARNING
+));
+```
+
+
+
+
+%package help
+Summary: Development documents and examples for renovosolutions.aws-cdk-aspects-security-group
+Provides: python3-renovosolutions.aws-cdk-aspects-security-group-doc
+%description help
+# cdk-aspects-library-security-group
+
+[![build](https://github.com/RenovoSolutions/cdk-aspects-library-security-group/actions/workflows/build.yml/badge.svg)](https://github.com/RenovoSolutions/cdk-aspects-library-security-group/actions/workflows/build.yml)
+
+A CDK library containing EC2 security group related [CDK Aspects](https://docs.aws.amazon.com/cdk/latest/guide/aspects.html) and the ability to define custom aspects.
+
+## Features
+
+* Utilize built in aspects for common cases:
+
+ * Disallow public access to any port
+ * Disallow public access to AWS Restricted Common ports ([per the AWS Config rule](https://docs.aws.amazon.com/config/latest/developerguide/restricted-common-ports.html))
+ * Disallow public access to SSH or RDP per CIS Benchmark guidelines and general good practice
+ * Disallow public or ALL access to common management ports like SSH, RDP, WinRM, WinRM over HTTPS
+ * Disallow public or ALL access common relational DB ports like MSSQL, MySQL, PostgreSQL, and Oracle
+ * Disallow public or ALL common web ports like HTTP (80, 8080) and HTTPS (443, 8443)
+* Create any other aspect using the base security group aspect class.
+* By default aspects generate errors in the CDK metadata which the deployment or synth process will find, but this can be changed with the `annotationType` property
+* All default provided aspects restrict based on the public access CIDRs (`0.0.0.0/0` and `::/0`) but you can also defined aspects with any set of restricted CIDRs or security group IDs you like
+
+## API Doc
+
+See [API](API.md)
+
+## Examples
+
+### Typescript
+
+```
+// Add an existing aspect to your stack
+Aspects.of(stack).add(new NoPublicIngressAspect());
+
+// Add a custom aspect to your stack
+Aspects.of(stack).add(new SecurityGroupAspectBase({
+ annotationText: 'This is a custom message warning you how you should not do what you are doing.',
+ annotationType: AnnotationType.WARNING,
+ ports: [5985],
+ restrictedCidrs: ['10.1.0.0/16'],
+}));
+
+// Change an existing aspects message and type
+Aspects.of(stack).add(new NoPublicIngressAspect(
+ annotationText: 'This is custom text.',
+ annotationType: AnnotationType.WARNING
+));
+```
+
+
+
+
+%prep
+%autosetup -n renovosolutions.aws-cdk-aspects-security-group-2.1.100
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-renovosolutions.aws-cdk-aspects-security-group -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.100-1
+- Package Spec generated