summaryrefslogtreecommitdiff
path: root/python-reposmon.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-reposmon.spec')
-rw-r--r--python-reposmon.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-reposmon.spec b/python-reposmon.spec
new file mode 100644
index 0000000..95d250b
--- /dev/null
+++ b/python-reposmon.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-reposmon
+Version: 70
+Release: 1
+Summary: Monitor a git repository, execute a command when it changes. Basically a polling git-hook for pull.
+License: GPL
+URL: https://github.com/erikdejonge/reposmon
+Source0: https://mirrors.aliyun.com/pypi/web/packages/5a/ce/6859607e1849fca2c3d1cda4d528505c40872b9ed6d021a48c938c14ded9/reposmon-70.tar.gz
+BuildArch: noarch
+
+
+%description
+readme: https://github.com/erikdejonge/reposmon
+
+
+%package -n python3-reposmon
+Summary: Monitor a git repository, execute a command when it changes. Basically a polling git-hook for pull.
+Provides: python-reposmon
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-reposmon
+readme: https://github.com/erikdejonge/reposmon
+
+
+%package help
+Summary: Development documents and examples for reposmon
+Provides: python3-reposmon-doc
+%description help
+readme: https://github.com/erikdejonge/reposmon
+
+
+%prep
+%autosetup -n reposmon-70
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-reposmon -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 70-1
+- Package Spec generated