summaryrefslogtreecommitdiff
path: root/python-requests-pkcs12.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-requests-pkcs12.spec')
-rw-r--r--python-requests-pkcs12.spec87
1 files changed, 87 insertions, 0 deletions
diff --git a/python-requests-pkcs12.spec b/python-requests-pkcs12.spec
new file mode 100644
index 0000000..629a5d8
--- /dev/null
+++ b/python-requests-pkcs12.spec
@@ -0,0 +1,87 @@
+%global _empty_manifest_terminate_build 0
+Name: python-requests-pkcs12
+Version: 1.15
+Release: 1
+Summary: Add PKCS#12 support to the requests library in a clean way, without monkey patching or temporary files
+License: ISC
+URL: https://github.com/m-click/requests_pkcs12
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d1/b5/be83fd3450a0a57a65e8d36e8f06b41abfcc4c43c61cad635c233a988fed/requests_pkcs12-1.15.tar.gz
+BuildArch: noarch
+
+Requires: python3-cryptography
+Requires: python3-pyOpenSSL
+Requires: python3-requests
+Requires: python3-urllib3
+Requires: python3-twine
+Requires: python3-wheel
+
+%description
+This library adds PKCS#12 support to the Python `requests <http://python-requests.org>`__ library.
+It is a **clean implementation**: it uses neither monkey patching nor temporary files. Instead, it is integrated into ``requests`` as
+recommended by its authors: creating a custom ``TransportAdapter``, which provides a custom ``SSLContext``.
+This library is meant to be a transitional solution until this functionality is provided by ``requests`` directly. However, that will take some time. See the `corresponding issue <https://github.com/requests/requests/issues/1573>`__ for more details.
+
+%package -n python3-requests-pkcs12
+Summary: Add PKCS#12 support to the requests library in a clean way, without monkey patching or temporary files
+Provides: python-requests-pkcs12
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-requests-pkcs12
+This library adds PKCS#12 support to the Python `requests <http://python-requests.org>`__ library.
+It is a **clean implementation**: it uses neither monkey patching nor temporary files. Instead, it is integrated into ``requests`` as
+recommended by its authors: creating a custom ``TransportAdapter``, which provides a custom ``SSLContext``.
+This library is meant to be a transitional solution until this functionality is provided by ``requests`` directly. However, that will take some time. See the `corresponding issue <https://github.com/requests/requests/issues/1573>`__ for more details.
+
+%package help
+Summary: Development documents and examples for requests-pkcs12
+Provides: python3-requests-pkcs12-doc
+%description help
+This library adds PKCS#12 support to the Python `requests <http://python-requests.org>`__ library.
+It is a **clean implementation**: it uses neither monkey patching nor temporary files. Instead, it is integrated into ``requests`` as
+recommended by its authors: creating a custom ``TransportAdapter``, which provides a custom ``SSLContext``.
+This library is meant to be a transitional solution until this functionality is provided by ``requests`` directly. However, that will take some time. See the `corresponding issue <https://github.com/requests/requests/issues/1573>`__ for more details.
+
+%prep
+%autosetup -n requests-pkcs12-1.15
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-requests-pkcs12 -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 1.15-1
+- Package Spec generated