summaryrefslogtreecommitdiff
path: root/python-rescape-region.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-rescape-region.spec')
-rw-r--r--python-rescape-region.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-rescape-region.spec b/python-rescape-region.spec
new file mode 100644
index 0000000..e1a2eea
--- /dev/null
+++ b/python-rescape-region.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-rescape-region
+Version: 0.2.37
+Release: 1
+Summary: Geospatial region support for Rescape projects
+License: MIT License
+URL: https://github.com/calocan/rescape_region
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a3/17/3b5a7cf3b29c798d0543523eef9bc4e98c3d5fdb14e317f06db54ee63e98/rescape-region-0.2.37.tar.gz
+BuildArch: noarch
+
+Requires: python3-pyramda
+Requires: python3-inflection
+Requires: python3-deepmerge
+
+%description
+
+
+%package -n python3-rescape-region
+Summary: Geospatial region support for Rescape projects
+Provides: python-rescape-region
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-rescape-region
+
+
+%package help
+Summary: Development documents and examples for rescape-region
+Provides: python3-rescape-region-doc
+%description help
+
+
+%prep
+%autosetup -n rescape-region-0.2.37
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-rescape-region -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.37-1
+- Package Spec generated