summaryrefslogtreecommitdiff
path: root/python-retrying.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 08:18:46 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 08:18:46 +0000
commitf29f68b021d20913998dda00c588a0ff9c9d42e3 (patch)
treeacbbae96cb5dc6d51cd9fc8625314771b1b74511 /python-retrying.spec
parent3654c715cdd8f70531757dc5a8d2799d219788e4 (diff)
automatic import of python-retrying
Diffstat (limited to 'python-retrying.spec')
-rw-r--r--python-retrying.spec109
1 files changed, 109 insertions, 0 deletions
diff --git a/python-retrying.spec b/python-retrying.spec
new file mode 100644
index 0000000..08de76b
--- /dev/null
+++ b/python-retrying.spec
@@ -0,0 +1,109 @@
+%global _empty_manifest_terminate_build 0
+Name: python-retrying
+Version: 1.3.4
+Release: 1
+Summary: Retrying
+License: Apache 2.0
+URL: https://github.com/groodt/retrying
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ce/70/15ce8551d65b324e18c5aa6ef6998880f21ead51ebe5ed743c0950d7d9dd/retrying-1.3.4.tar.gz
+BuildArch: noarch
+
+Requires: python3-six
+
+%description
+Retrying is an Apache 2.0 licensed general-purpose retrying library, written in
+Python, to simplify the task of adding retry behavior to just about anything.
+The simplest use case is retrying a flaky function whenever an Exception occurs
+until a value is returned.
+ import random
+ from retrying import retry
+ @retry
+ def do_something_unreliable():
+ if random.randint(0, 10) > 1:
+ raise IOError("Broken sauce, everything is hosed!!!111one")
+ else:
+ return "Awesome sauce!"
+ print do_something_unreliable()
+
+%package -n python3-retrying
+Summary: Retrying
+Provides: python-retrying
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-retrying
+Retrying is an Apache 2.0 licensed general-purpose retrying library, written in
+Python, to simplify the task of adding retry behavior to just about anything.
+The simplest use case is retrying a flaky function whenever an Exception occurs
+until a value is returned.
+ import random
+ from retrying import retry
+ @retry
+ def do_something_unreliable():
+ if random.randint(0, 10) > 1:
+ raise IOError("Broken sauce, everything is hosed!!!111one")
+ else:
+ return "Awesome sauce!"
+ print do_something_unreliable()
+
+%package help
+Summary: Development documents and examples for retrying
+Provides: python3-retrying-doc
+%description help
+Retrying is an Apache 2.0 licensed general-purpose retrying library, written in
+Python, to simplify the task of adding retry behavior to just about anything.
+The simplest use case is retrying a flaky function whenever an Exception occurs
+until a value is returned.
+ import random
+ from retrying import retry
+ @retry
+ def do_something_unreliable():
+ if random.randint(0, 10) > 1:
+ raise IOError("Broken sauce, everything is hosed!!!111one")
+ else:
+ return "Awesome sauce!"
+ print do_something_unreliable()
+
+%prep
+%autosetup -n retrying-1.3.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-retrying -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.4-1
+- Package Spec generated