summaryrefslogtreecommitdiff
path: root/python-ring.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-ring.spec')
-rw-r--r--python-ring.spec90
1 files changed, 90 insertions, 0 deletions
diff --git a/python-ring.spec b/python-ring.spec
new file mode 100644
index 0000000..b60aa20
--- /dev/null
+++ b/python-ring.spec
@@ -0,0 +1,90 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ring
+Version: 0.10.1
+Release: 1
+Summary: Function-oriented cache interface with built-in memcache & redis + asyncio support.
+License: BSD License
+URL: https://github.com/youknowone/ring
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/50/77/863775e66d19f32f0264cd4e806c6247c9907d544ccca350b8b0e18ed412/ring-0.10.1.tar.gz
+BuildArch: noarch
+
+
+%description
+Let's concentrate on code, not on storages.
+Ring shows a way to control cache in point of view of code - not about storages.
+Ring's decorator is convenient but also keeps fluency for general scenarios.
+asyncio support for Python3.5+!
+Take advantage of perfectly explicit and fully automated cache interface.
+Ring decorators convert your functions to cached version of them, with extra
+control methods.
+
+%package -n python3-ring
+Summary: Function-oriented cache interface with built-in memcache & redis + asyncio support.
+Provides: python-ring
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-ring
+Let's concentrate on code, not on storages.
+Ring shows a way to control cache in point of view of code - not about storages.
+Ring's decorator is convenient but also keeps fluency for general scenarios.
+asyncio support for Python3.5+!
+Take advantage of perfectly explicit and fully automated cache interface.
+Ring decorators convert your functions to cached version of them, with extra
+control methods.
+
+%package help
+Summary: Development documents and examples for ring
+Provides: python3-ring-doc
+%description help
+Let's concentrate on code, not on storages.
+Ring shows a way to control cache in point of view of code - not about storages.
+Ring's decorator is convenient but also keeps fluency for general scenarios.
+asyncio support for Python3.5+!
+Take advantage of perfectly explicit and fully automated cache interface.
+Ring decorators convert your functions to cached version of them, with extra
+control methods.
+
+%prep
+%autosetup -n ring-0.10.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ring -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 0.10.1-1
+- Package Spec generated