summaryrefslogtreecommitdiff
path: root/python-rpcq.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 00:14:31 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 00:14:31 +0000
commite410b3d39404a444b506a81fe4e727d3ae4e5f56 (patch)
tree4c338401eaf8138f6f30d14206ddec1f141d594b /python-rpcq.spec
parented0b23156ab339a8a7ba5951076e3c9dfe4114a3 (diff)
automatic import of python-rpcq
Diffstat (limited to 'python-rpcq.spec')
-rw-r--r--python-rpcq.spec96
1 files changed, 96 insertions, 0 deletions
diff --git a/python-rpcq.spec b/python-rpcq.spec
new file mode 100644
index 0000000..90703ab
--- /dev/null
+++ b/python-rpcq.spec
@@ -0,0 +1,96 @@
+%global _empty_manifest_terminate_build 0
+Name: python-rpcq
+Version: 3.11.0
+Release: 1
+Summary: The RPC framework and message specification for Rigetti QCS.
+License: Apache-2.0
+URL: https://github.com/rigetticomputing/rpcq.git
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b3/02/6113b7dedf92169486d2ea000875000f54920cbf3887f90fd102aa061e83/rpcq-3.11.0.tar.gz
+BuildArch: noarch
+
+
+%description
+[![pypi version](https://img.shields.io/pypi/v/rpcq.svg)](https://pypi.org/project/rpcq/)
+[![conda-forge version](https://img.shields.io/conda/vn/conda-forge/rpcq.svg)](https://anaconda.org/conda-forge/rpcq)
+[![docker pulls](https://img.shields.io/docker/pulls/rigetti/rpcq.svg)](https://hub.docker.com/r/rigetti/rpcq)
+The asynchronous RPC client-server framework and message specification for
+[Rigetti Quantum Cloud Services (QCS)](https://www.rigetti.com/).
+Implements an efficient transport protocol by using [ZeroMQ](http://zeromq.org/) (ZMQ) sockets and
+[MessagePack](https://msgpack.org/index.html) (`msgpack`) serialization.
+Not intended to be a full-featured replacement for other frameworks like
+[gRPC](https://grpc.io/) or [Apache Thrift](https://thrift.apache.org/).
+
+%package -n python3-rpcq
+Summary: The RPC framework and message specification for Rigetti QCS.
+Provides: python-rpcq
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-rpcq
+[![pypi version](https://img.shields.io/pypi/v/rpcq.svg)](https://pypi.org/project/rpcq/)
+[![conda-forge version](https://img.shields.io/conda/vn/conda-forge/rpcq.svg)](https://anaconda.org/conda-forge/rpcq)
+[![docker pulls](https://img.shields.io/docker/pulls/rigetti/rpcq.svg)](https://hub.docker.com/r/rigetti/rpcq)
+The asynchronous RPC client-server framework and message specification for
+[Rigetti Quantum Cloud Services (QCS)](https://www.rigetti.com/).
+Implements an efficient transport protocol by using [ZeroMQ](http://zeromq.org/) (ZMQ) sockets and
+[MessagePack](https://msgpack.org/index.html) (`msgpack`) serialization.
+Not intended to be a full-featured replacement for other frameworks like
+[gRPC](https://grpc.io/) or [Apache Thrift](https://thrift.apache.org/).
+
+%package help
+Summary: Development documents and examples for rpcq
+Provides: python3-rpcq-doc
+%description help
+[![pypi version](https://img.shields.io/pypi/v/rpcq.svg)](https://pypi.org/project/rpcq/)
+[![conda-forge version](https://img.shields.io/conda/vn/conda-forge/rpcq.svg)](https://anaconda.org/conda-forge/rpcq)
+[![docker pulls](https://img.shields.io/docker/pulls/rigetti/rpcq.svg)](https://hub.docker.com/r/rigetti/rpcq)
+The asynchronous RPC client-server framework and message specification for
+[Rigetti Quantum Cloud Services (QCS)](https://www.rigetti.com/).
+Implements an efficient transport protocol by using [ZeroMQ](http://zeromq.org/) (ZMQ) sockets and
+[MessagePack](https://msgpack.org/index.html) (`msgpack`) serialization.
+Not intended to be a full-featured replacement for other frameworks like
+[gRPC](https://grpc.io/) or [Apache Thrift](https://thrift.apache.org/).
+
+%prep
+%autosetup -n rpcq-3.11.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-rpcq -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 3.11.0-1
+- Package Spec generated