summaryrefslogtreecommitdiff
path: root/python-rplcd.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-29 12:44:40 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-29 12:44:40 +0000
commitbfe09b5adb4e980bc409e3fc7218d28c08b2d01f (patch)
tree8c23dd16a4753ec22c9e69e29917681f6844c3e7 /python-rplcd.spec
parentb7250e9934b4b55caf4b1ad5ecdfa5f9302fbf2a (diff)
automatic import of python-rplcd
Diffstat (limited to 'python-rplcd.spec')
-rw-r--r--python-rplcd.spec105
1 files changed, 105 insertions, 0 deletions
diff --git a/python-rplcd.spec b/python-rplcd.spec
new file mode 100644
index 0000000..e2fc92b
--- /dev/null
+++ b/python-rplcd.spec
@@ -0,0 +1,105 @@
+%global _empty_manifest_terminate_build 0
+Name: python-RPLCD
+Version: 1.3.1
+Release: 1
+Summary: A Raspberry Pi LCD library for the widely used Hitachi HD44780 controller.
+License: MIT
+URL: https://github.com/dbrgn/RPLCD
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7f/f7/9860cc59f12fcb80ced36b45ce05dd321f381b8ff3d00b79ad48bcbd96b9/RPLCD-1.3.1.tar.gz
+BuildArch: noarch
+
+
+%description
+You can install RPLCD directly from `PyPI
+<https://pypi.python.org/pypi/RPLCD/>`_ using pip::
+ $ sudo pip install RPLCD
+If you want to use I²C, you also need either the smbus or `smbus2 <https://pypi.org/project/smbus2/>`_ library::
+ $ sudo apt install python-smbus
+ or
+ $ sudo pip install smbus2
+RPLCD will first try to use smbus if available and if not, fall back to smbus2.
+You can also install the library manually without pip. Either just copy the
+scripts to your working directory and import them, or download the repository
+and run ``python setup.py install`` to install it into your Python package
+directory.
+
+%package -n python3-RPLCD
+Summary: A Raspberry Pi LCD library for the widely used Hitachi HD44780 controller.
+Provides: python-RPLCD
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-RPLCD
+You can install RPLCD directly from `PyPI
+<https://pypi.python.org/pypi/RPLCD/>`_ using pip::
+ $ sudo pip install RPLCD
+If you want to use I²C, you also need either the smbus or `smbus2 <https://pypi.org/project/smbus2/>`_ library::
+ $ sudo apt install python-smbus
+ or
+ $ sudo pip install smbus2
+RPLCD will first try to use smbus if available and if not, fall back to smbus2.
+You can also install the library manually without pip. Either just copy the
+scripts to your working directory and import them, or download the repository
+and run ``python setup.py install`` to install it into your Python package
+directory.
+
+%package help
+Summary: Development documents and examples for RPLCD
+Provides: python3-RPLCD-doc
+%description help
+You can install RPLCD directly from `PyPI
+<https://pypi.python.org/pypi/RPLCD/>`_ using pip::
+ $ sudo pip install RPLCD
+If you want to use I²C, you also need either the smbus or `smbus2 <https://pypi.org/project/smbus2/>`_ library::
+ $ sudo apt install python-smbus
+ or
+ $ sudo pip install smbus2
+RPLCD will first try to use smbus if available and if not, fall back to smbus2.
+You can also install the library manually without pip. Either just copy the
+scripts to your working directory and import them, or download the repository
+and run ``python setup.py install`` to install it into your Python package
+directory.
+
+%prep
+%autosetup -n RPLCD-1.3.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-RPLCD -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.1-1
+- Package Spec generated