summaryrefslogtreecommitdiff
path: root/python-sabyenc3.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-05 07:30:55 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-05 07:30:55 +0000
commit3648b495123b4d2a43ec5c447ec873b93f59fcc9 (patch)
treea3c614d362bf9a1d8f0de7a3b7a06c0a8b9f1a4e /python-sabyenc3.spec
parent0a351314f2ebf099b5f95805ec8b66c8803c4cff (diff)
automatic import of python-sabyenc3openeuler20.03
Diffstat (limited to 'python-sabyenc3.spec')
-rw-r--r--python-sabyenc3.spec89
1 files changed, 89 insertions, 0 deletions
diff --git a/python-sabyenc3.spec b/python-sabyenc3.spec
new file mode 100644
index 0000000..39400a4
--- /dev/null
+++ b/python-sabyenc3.spec
@@ -0,0 +1,89 @@
+%global _empty_manifest_terminate_build 0
+Name: python-sabyenc3
+Version: 5.4.4
+Release: 1
+Summary: yEnc decoding of usenet data using SIMD routines
+License: LGPLv3
+URL: https://github.com/sabnzbd/sabyenc/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/15/30/4e0c449cac8a104f8ef32ae6559cc97ad5eb3610ca94584cdfc5e5dde416/sabyenc3-5.4.4.tar.gz
+
+
+%description
+Modification of the original [yenc](https://pypi.org/project/yenc/) module for use within SABnzbd.
+The module was extended to do header parsing and full yEnc decoding from a Python
+list of chunks, the way in which data is retrieved from Usenet.
+This is particularly beneficial when SSL is enabled, which limits the size of each chunk to 16K. Parsing these chunks in python is much more costly.
+Additionally, this module releases Python's GIL during decoding, greatly increasing performance of the overall download process.
+Further improved by using [yencode](https://github.com/animetosho/node-yencode) from animetosho, which utilizes x86/ARM SIMD optimised routines if such CPU features are available.
+
+%package -n python3-sabyenc3
+Summary: yEnc decoding of usenet data using SIMD routines
+Provides: python-sabyenc3
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-sabyenc3
+Modification of the original [yenc](https://pypi.org/project/yenc/) module for use within SABnzbd.
+The module was extended to do header parsing and full yEnc decoding from a Python
+list of chunks, the way in which data is retrieved from Usenet.
+This is particularly beneficial when SSL is enabled, which limits the size of each chunk to 16K. Parsing these chunks in python is much more costly.
+Additionally, this module releases Python's GIL during decoding, greatly increasing performance of the overall download process.
+Further improved by using [yencode](https://github.com/animetosho/node-yencode) from animetosho, which utilizes x86/ARM SIMD optimised routines if such CPU features are available.
+
+%package help
+Summary: Development documents and examples for sabyenc3
+Provides: python3-sabyenc3-doc
+%description help
+Modification of the original [yenc](https://pypi.org/project/yenc/) module for use within SABnzbd.
+The module was extended to do header parsing and full yEnc decoding from a Python
+list of chunks, the way in which data is retrieved from Usenet.
+This is particularly beneficial when SSL is enabled, which limits the size of each chunk to 16K. Parsing these chunks in python is much more costly.
+Additionally, this module releases Python's GIL during decoding, greatly increasing performance of the overall download process.
+Further improved by using [yencode](https://github.com/animetosho/node-yencode) from animetosho, which utilizes x86/ARM SIMD optimised routines if such CPU features are available.
+
+%prep
+%autosetup -n sabyenc3-5.4.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-sabyenc3 -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 5.4.4-1
+- Package Spec generated