summaryrefslogtreecommitdiff
path: root/python-scikit-learn.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-scikit-learn.spec')
-rw-r--r--python-scikit-learn.spec129
1 files changed, 129 insertions, 0 deletions
diff --git a/python-scikit-learn.spec b/python-scikit-learn.spec
new file mode 100644
index 0000000..df97839
--- /dev/null
+++ b/python-scikit-learn.spec
@@ -0,0 +1,129 @@
+%global _empty_manifest_terminate_build 0
+Name: python-scikit-learn
+Version: 1.2.2
+Release: 1
+Summary: A set of python modules for machine learning and data mining
+License: new BSD
+URL: http://scikit-learn.org
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c9/fa/8e158d81e3602da1e7bafbd4987938bc003fe4b0f44d65681e7f8face95a/scikit-learn-1.2.2.tar.gz
+
+Requires: python3-numpy
+Requires: python3-scipy
+Requires: python3-joblib
+Requires: python3-threadpoolctl
+Requires: python3-matplotlib
+Requires: python3-pandas
+Requires: python3-memory-profiler
+Requires: python3-matplotlib
+Requires: python3-scikit-image
+Requires: python3-pandas
+Requires: python3-seaborn
+Requires: python3-memory-profiler
+Requires: python3-sphinx
+Requires: python3-sphinx-gallery
+Requires: python3-numpydoc
+Requires: python3-Pillow
+Requires: python3-pooch
+Requires: python3-sphinx-prompt
+Requires: python3-sphinxext-opengraph
+Requires: python3-plotly
+Requires: python3-matplotlib
+Requires: python3-scikit-image
+Requires: python3-pandas
+Requires: python3-seaborn
+Requires: python3-pooch
+Requires: python3-plotly
+Requires: python3-matplotlib
+Requires: python3-scikit-image
+Requires: python3-pandas
+Requires: python3-pytest
+Requires: python3-pytest-cov
+Requires: python3-flake8
+Requires: python3-black
+Requires: python3-mypy
+Requires: python3-pyamg
+Requires: python3-numpydoc
+Requires: python3-pooch
+
+%description
+Dependencies
+~~~~~~~~~~~~
+scikit-learn requires:
+- Python (>= |PythonMinVersion|)
+- NumPy (>= |NumPyMinVersion|)
+- SciPy (>= |SciPyMinVersion|)
+- joblib (>= |JoblibMinVersion|)
+
+%package -n python3-scikit-learn
+Summary: A set of python modules for machine learning and data mining
+Provides: python-scikit-learn
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-scikit-learn
+Dependencies
+~~~~~~~~~~~~
+scikit-learn requires:
+- Python (>= |PythonMinVersion|)
+- NumPy (>= |NumPyMinVersion|)
+- SciPy (>= |SciPyMinVersion|)
+- joblib (>= |JoblibMinVersion|)
+
+%package help
+Summary: Development documents and examples for scikit-learn
+Provides: python3-scikit-learn-doc
+%description help
+Dependencies
+~~~~~~~~~~~~
+scikit-learn requires:
+- Python (>= |PythonMinVersion|)
+- NumPy (>= |NumPyMinVersion|)
+- SciPy (>= |SciPyMinVersion|)
+- joblib (>= |JoblibMinVersion|)
+
+%prep
+%autosetup -n scikit-learn-1.2.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-scikit-learn -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.2-1
+- Package Spec generated