summaryrefslogtreecommitdiff
path: root/python-scratchencoder.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-scratchencoder.spec')
-rw-r--r--python-scratchencoder.spec156
1 files changed, 156 insertions, 0 deletions
diff --git a/python-scratchencoder.spec b/python-scratchencoder.spec
new file mode 100644
index 0000000..c9345cc
--- /dev/null
+++ b/python-scratchencoder.spec
@@ -0,0 +1,156 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ScratchEncoder
+Version: 0.1.6
+Release: 1
+Summary: Scratch Encoder
+License: MIT
+URL: https://github.com/The-Cloud-Dev/ScratchEncoder
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/46/4b/df76b1908dc5c193a9bea94736249353cca5aa80919e11138c02142b3d5a/ScratchEncoder-0.1.6.tar.gz
+BuildArch: noarch
+
+
+%description
+# ScratchEncoder
+
+## Installation
+
+```bash
+pip install ScratchEncoder
+```
+
+## Usage
+
+```python
+encoder = scratchencoder.Encoder()
+```
+
+Initializes a new encoder object.
+
+## Encoding
+
+```python
+encoder.encode('Text')
+# Encodes text and returns the encoded value
+encoder.decode('value')
+# Decodes a value and returns the decoded text
+```
+
+## Scratch
+
+View the project on scratch [here](https://scratch.mit.edu/projects/546443308)
+Contact me on my [Scratch Profile](https://scratch.mit.edu/users/TheCloudDev/#comments)
+
+%package -n python3-ScratchEncoder
+Summary: Scratch Encoder
+Provides: python-ScratchEncoder
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-ScratchEncoder
+# ScratchEncoder
+
+## Installation
+
+```bash
+pip install ScratchEncoder
+```
+
+## Usage
+
+```python
+encoder = scratchencoder.Encoder()
+```
+
+Initializes a new encoder object.
+
+## Encoding
+
+```python
+encoder.encode('Text')
+# Encodes text and returns the encoded value
+encoder.decode('value')
+# Decodes a value and returns the decoded text
+```
+
+## Scratch
+
+View the project on scratch [here](https://scratch.mit.edu/projects/546443308)
+Contact me on my [Scratch Profile](https://scratch.mit.edu/users/TheCloudDev/#comments)
+
+%package help
+Summary: Development documents and examples for ScratchEncoder
+Provides: python3-ScratchEncoder-doc
+%description help
+# ScratchEncoder
+
+## Installation
+
+```bash
+pip install ScratchEncoder
+```
+
+## Usage
+
+```python
+encoder = scratchencoder.Encoder()
+```
+
+Initializes a new encoder object.
+
+## Encoding
+
+```python
+encoder.encode('Text')
+# Encodes text and returns the encoded value
+encoder.decode('value')
+# Decodes a value and returns the decoded text
+```
+
+## Scratch
+
+View the project on scratch [here](https://scratch.mit.edu/projects/546443308)
+Contact me on my [Scratch Profile](https://scratch.mit.edu/users/TheCloudDev/#comments)
+
+%prep
+%autosetup -n ScratchEncoder-0.1.6
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ScratchEncoder -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.6-1
+- Package Spec generated