summaryrefslogtreecommitdiff
path: root/python-screenlogicpy.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 08:56:47 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 08:56:47 +0000
commit0c8ac4418bd4794d0689983affbeed9935173065 (patch)
tree0baa6ab64a5e794f2e252e5f0b270a8a9f8aaacf /python-screenlogicpy.spec
parent3c87c9750cf0188099f19288b1c4cfbdb945f8d8 (diff)
automatic import of python-screenlogicpy
Diffstat (limited to 'python-screenlogicpy.spec')
-rw-r--r--python-screenlogicpy.spec79
1 files changed, 79 insertions, 0 deletions
diff --git a/python-screenlogicpy.spec b/python-screenlogicpy.spec
new file mode 100644
index 0000000..6b8c04a
--- /dev/null
+++ b/python-screenlogicpy.spec
@@ -0,0 +1,79 @@
+%global _empty_manifest_terminate_build 0
+Name: python-screenlogicpy
+Version: 0.9.0
+Release: 1
+Summary: Interface for Pentair ScreenLogic connected pool controllers over IP via Python
+License: GPLv3
+URL: https://github.com/dieselrabbit/screenlogicpy
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ab/ec/df6ad092936fe75b4d8403960bd920e2d17c13dd23c7e6804488e4c2c211/screenlogicpy-0.9.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-async-timeout
+
+%description
+Spa temperature is last 97°F
+Spa Heat Set Point: 97°F
+Spa Heat: Off
+
+%package -n python3-screenlogicpy
+Summary: Interface for Pentair ScreenLogic connected pool controllers over IP via Python
+Provides: python-screenlogicpy
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-screenlogicpy
+Spa temperature is last 97°F
+Spa Heat Set Point: 97°F
+Spa Heat: Off
+
+%package help
+Summary: Development documents and examples for screenlogicpy
+Provides: python3-screenlogicpy-doc
+%description help
+Spa temperature is last 97°F
+Spa Heat Set Point: 97°F
+Spa Heat: Off
+
+%prep
+%autosetup -n screenlogicpy-0.9.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-screenlogicpy -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.0-1
+- Package Spec generated