summaryrefslogtreecommitdiff
path: root/python-sengiri.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-sengiri.spec')
-rw-r--r--python-sengiri.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-sengiri.spec b/python-sengiri.spec
new file mode 100644
index 0000000..6719989
--- /dev/null
+++ b/python-sengiri.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-sengiri
+Version: 0.2.1
+Release: 1
+Summary: Yet another sentence-level tokenizer for the Japanese text
+License: MIT License
+URL: https://github.com/ikegami-yukino/sengiri
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/66/51/584352e8c50c2d73696c40b3be8a78b6eab7ee3db7b021c1c7e247ceb399/sengiri-0.2.1.tar.gz
+BuildArch: noarch
+
+
+%description
+|travis| |coveralls| |pyversion| |version| |license|
+Yet another sentence-level tokenizer for the Japanese text
+
+%package -n python3-sengiri
+Summary: Yet another sentence-level tokenizer for the Japanese text
+Provides: python-sengiri
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-sengiri
+|travis| |coveralls| |pyversion| |version| |license|
+Yet another sentence-level tokenizer for the Japanese text
+
+%package help
+Summary: Development documents and examples for sengiri
+Provides: python3-sengiri-doc
+%description help
+|travis| |coveralls| |pyversion| |version| |license|
+Yet another sentence-level tokenizer for the Japanese text
+
+%prep
+%autosetup -n sengiri-0.2.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-sengiri -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.1-1
+- Package Spec generated