summaryrefslogtreecommitdiff
path: root/python-sharestats-item-editor.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-06-20 09:57:31 +0000
committerCoprDistGit <infra@openeuler.org>2023-06-20 09:57:31 +0000
commitb5d5a832df13cda814fa5e246d047d841874f635 (patch)
tree7afb6d16cc5bd1421a852cd8ff64db830aedce66 /python-sharestats-item-editor.spec
parentec86f707c0e596bcf4f688c6c95ca613346197ad (diff)
automatic import of python-sharestats-item-editoropeneuler20.03
Diffstat (limited to 'python-sharestats-item-editor.spec')
-rw-r--r--python-sharestats-item-editor.spec194
1 files changed, 194 insertions, 0 deletions
diff --git a/python-sharestats-item-editor.spec b/python-sharestats-item-editor.spec
new file mode 100644
index 0000000..b4cf287
--- /dev/null
+++ b/python-sharestats-item-editor.spec
@@ -0,0 +1,194 @@
+%global _empty_manifest_terminate_build 0
+Name: python-sharestats-item-editor
+Version: 0.2.11.post2
+Release: 1
+Summary: Editor and validator for Rexam items in the ShareStats project
+License: MIT licence
+URL: https://github.com/lindemann09/rexam-item-editor
+Source0: https://mirrors.aliyun.com/pypi/web/packages/15/9c/e140e49187cef885be9c22a719bf12274fe485debd3b1e5de274af5c39a1/sharestats-item-editor-0.2.11.post2.tar.gz
+BuildArch: noarch
+
+Requires: python3-PyYAML
+Requires: python3-appdirs
+Requires: python3-pysimplegui
+Requires: python3-Markdown
+Requires: python3-rpy2
+
+%description
+## Installation
+Please, ensure that [Python 3](https://www.python.org/downloads/) is installed on your
+computer. If you install Python 3 on Windows, don't for get to [add Python the path](https://pychill.info/wp-content/uploads/2020/06/installation_python-1.jpg) environment variable.
+*ShareStats-Item-Editor* can be installed via the Pythons package manager
+`pip`. Open a shell and call:
+```
+python -m pip install -U sharestats-item-editor
+```
+(This command is also used the update an existsing installing of *ShareStats-Item-Editor*.)
+To run *ShareStats-Item-Editor* called this command via your shell:
+```
+sharestats-item-editor
+```
+### Windows Executables
+Windows user may run *StatsShare-Item-Editor* without installing `Python`.
+Download the latest executable file, `sharestats_item_editor.exe`, via the
+[release website](https://github.com/essb-mt-section/sharestats-item-editor/releases/latest)
+and execute it.
+Note, depending on your security settings, you may receive a security alert
+from Windows defender, because the executable is not a registered Windows
+application.
+Using this installation method is convenient has however two disadvantages.
+(a) Windows may classify the executable erroneously as a virus and prevents
+you from installing.
+(b) Using the executable instead of installing the application via `pip` results
+in a slow launching application.
+## Dependencies
+Python 3.7+ and the following libraries (see [requirements.txt](requirements.txt)):
+* PySimpleGUI
+* appdirs
+Optional requirement:
+* rpy2 >=3.4
+* markdown >=3.0
+## Rendering Rmd File (work in progress)
+To render Rmd files directly via the *StatsShare-Item-Editor*, you need
+a functioning
+installation of *R* including the *R*-package `exams`.
+If you don't use the Windows executable, install the Python-package `rpy2` (`pip install rpy2`).
+Windows user find two executable files for *StatsShare-Item-Editor*, one with
+and one without *R* rendering support. *StatsShare-Item-Editor* with
+
+%package -n python3-sharestats-item-editor
+Summary: Editor and validator for Rexam items in the ShareStats project
+Provides: python-sharestats-item-editor
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-sharestats-item-editor
+## Installation
+Please, ensure that [Python 3](https://www.python.org/downloads/) is installed on your
+computer. If you install Python 3 on Windows, don't for get to [add Python the path](https://pychill.info/wp-content/uploads/2020/06/installation_python-1.jpg) environment variable.
+*ShareStats-Item-Editor* can be installed via the Pythons package manager
+`pip`. Open a shell and call:
+```
+python -m pip install -U sharestats-item-editor
+```
+(This command is also used the update an existsing installing of *ShareStats-Item-Editor*.)
+To run *ShareStats-Item-Editor* called this command via your shell:
+```
+sharestats-item-editor
+```
+### Windows Executables
+Windows user may run *StatsShare-Item-Editor* without installing `Python`.
+Download the latest executable file, `sharestats_item_editor.exe`, via the
+[release website](https://github.com/essb-mt-section/sharestats-item-editor/releases/latest)
+and execute it.
+Note, depending on your security settings, you may receive a security alert
+from Windows defender, because the executable is not a registered Windows
+application.
+Using this installation method is convenient has however two disadvantages.
+(a) Windows may classify the executable erroneously as a virus and prevents
+you from installing.
+(b) Using the executable instead of installing the application via `pip` results
+in a slow launching application.
+## Dependencies
+Python 3.7+ and the following libraries (see [requirements.txt](requirements.txt)):
+* PySimpleGUI
+* appdirs
+Optional requirement:
+* rpy2 >=3.4
+* markdown >=3.0
+## Rendering Rmd File (work in progress)
+To render Rmd files directly via the *StatsShare-Item-Editor*, you need
+a functioning
+installation of *R* including the *R*-package `exams`.
+If you don't use the Windows executable, install the Python-package `rpy2` (`pip install rpy2`).
+Windows user find two executable files for *StatsShare-Item-Editor*, one with
+and one without *R* rendering support. *StatsShare-Item-Editor* with
+
+%package help
+Summary: Development documents and examples for sharestats-item-editor
+Provides: python3-sharestats-item-editor-doc
+%description help
+## Installation
+Please, ensure that [Python 3](https://www.python.org/downloads/) is installed on your
+computer. If you install Python 3 on Windows, don't for get to [add Python the path](https://pychill.info/wp-content/uploads/2020/06/installation_python-1.jpg) environment variable.
+*ShareStats-Item-Editor* can be installed via the Pythons package manager
+`pip`. Open a shell and call:
+```
+python -m pip install -U sharestats-item-editor
+```
+(This command is also used the update an existsing installing of *ShareStats-Item-Editor*.)
+To run *ShareStats-Item-Editor* called this command via your shell:
+```
+sharestats-item-editor
+```
+### Windows Executables
+Windows user may run *StatsShare-Item-Editor* without installing `Python`.
+Download the latest executable file, `sharestats_item_editor.exe`, via the
+[release website](https://github.com/essb-mt-section/sharestats-item-editor/releases/latest)
+and execute it.
+Note, depending on your security settings, you may receive a security alert
+from Windows defender, because the executable is not a registered Windows
+application.
+Using this installation method is convenient has however two disadvantages.
+(a) Windows may classify the executable erroneously as a virus and prevents
+you from installing.
+(b) Using the executable instead of installing the application via `pip` results
+in a slow launching application.
+## Dependencies
+Python 3.7+ and the following libraries (see [requirements.txt](requirements.txt)):
+* PySimpleGUI
+* appdirs
+Optional requirement:
+* rpy2 >=3.4
+* markdown >=3.0
+## Rendering Rmd File (work in progress)
+To render Rmd files directly via the *StatsShare-Item-Editor*, you need
+a functioning
+installation of *R* including the *R*-package `exams`.
+If you don't use the Windows executable, install the Python-package `rpy2` (`pip install rpy2`).
+Windows user find two executable files for *StatsShare-Item-Editor*, one with
+and one without *R* rendering support. *StatsShare-Item-Editor* with
+
+%prep
+%autosetup -n sharestats-item-editor-0.2.11.post2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-sharestats-item-editor -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.11.post2-1
+- Package Spec generated