summaryrefslogtreecommitdiff
path: root/python-signlanguagerecognition.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-05 06:19:37 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-05 06:19:37 +0000
commitd86cc8bdf46c8d959dde87c7a74c057120cc024a (patch)
tree5ce564bb8a8fd83ca9be280fe5c1bce9de23965c /python-signlanguagerecognition.spec
parentecfc5fcaecf9a270bd7cfc324ab75d85d640ef43 (diff)
automatic import of python-signlanguagerecognitionopeneuler20.03
Diffstat (limited to 'python-signlanguagerecognition.spec')
-rw-r--r--python-signlanguagerecognition.spec79
1 files changed, 79 insertions, 0 deletions
diff --git a/python-signlanguagerecognition.spec b/python-signlanguagerecognition.spec
new file mode 100644
index 0000000..2e105d7
--- /dev/null
+++ b/python-signlanguagerecognition.spec
@@ -0,0 +1,79 @@
+%global _empty_manifest_terminate_build 0
+Name: python-SignLanguageRecognition
+Version: 0.0.20.1
+Release: 1
+Summary: Sign Language Recognition tool.
+License: MIT License
+URL: https://github.com/JanBinkowski/SignLanguageRecognition
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/db/ed/edb369cbbbf0b42118d071ba611d499f3b2d029bd75e6435235c5f2407c2/SignLanguageRecognition-0.0.20.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-opencv-python
+Requires: python3-mediapipe
+Requires: python3-numpy
+Requires: python3-tensorflow
+
+%description
+## General info
+SignLanguageRecognition package is a opensource tool to estimate sign language from camera vision. This project is a part of my Bachelor Thesis and contains the implementation of sign language recognition tool using a LSTM Neural Network, TensorFlow Keras and other opensorce libraries like: OpenCV or MediaPipe.
+
+%package -n python3-SignLanguageRecognition
+Summary: Sign Language Recognition tool.
+Provides: python-SignLanguageRecognition
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-SignLanguageRecognition
+## General info
+SignLanguageRecognition package is a opensource tool to estimate sign language from camera vision. This project is a part of my Bachelor Thesis and contains the implementation of sign language recognition tool using a LSTM Neural Network, TensorFlow Keras and other opensorce libraries like: OpenCV or MediaPipe.
+
+%package help
+Summary: Development documents and examples for SignLanguageRecognition
+Provides: python3-SignLanguageRecognition-doc
+%description help
+## General info
+SignLanguageRecognition package is a opensource tool to estimate sign language from camera vision. This project is a part of my Bachelor Thesis and contains the implementation of sign language recognition tool using a LSTM Neural Network, TensorFlow Keras and other opensorce libraries like: OpenCV or MediaPipe.
+
+%prep
+%autosetup -n SignLanguageRecognition-0.0.20.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-SignLanguageRecognition -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.20.1-1
+- Package Spec generated