summaryrefslogtreecommitdiff
path: root/python-sparklines.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-29 11:38:40 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-29 11:38:40 +0000
commit1e7c53cc0cb5b2e7e3b893eb89f2c9868c05e482 (patch)
tree6de5d670efe8af835e573f360dac399d026f02a6 /python-sparklines.spec
parentd20853ae30538da4d6edcb4f8d733bb0b025b3e1 (diff)
automatic import of python-sparklines
Diffstat (limited to 'python-sparklines.spec')
-rw-r--r--python-sparklines.spec117
1 files changed, 117 insertions, 0 deletions
diff --git a/python-sparklines.spec b/python-sparklines.spec
new file mode 100644
index 0000000..2447551
--- /dev/null
+++ b/python-sparklines.spec
@@ -0,0 +1,117 @@
+%global _empty_manifest_terminate_build 0
+Name: python-sparklines
+Version: 0.4.2
+Release: 1
+Summary: Generate sparklines for numbers using Unicode characters only.
+License: GPL
+URL: https://github.com/deeplook/sparklines
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/04/0d/a4b03bacacb2e057680568757ec75b522077b93fa66fc14c1f2633d24b57/sparklines-0.4.2.tar.gz
+BuildArch: noarch
+
+
+%description
+|ci| |pypi|
+This Python package implements Edward Tufte's concept of sparklines_, but
+limited to text only e.g. like this: ▃▁▄▁▅█▂▅ (this I likely not displayed
+correctly in every browser). You can find more information about sparklines
+`on Wikipedia`_. This code was mainly developed for running simple
+plausibility tests in sensor networks as shown in fig. 1 below:
+ Fig. 1: Example usecase for such "sparklines" on the command-line,
+ showing IoT sensor values (generating code not included here).
+Due to limitations of available Unicode characters this works best when all
+values are positive. And even then true sparklines that look more like lines
+and less like bars are a real challenge, because they would need multiple
+characters with a single horizontal line on different vertical positions. This
+would work only with a dedicated font, which is way beyond the scope of this
+tool and which would significantly complicate its usage. So we stick to these
+characters: "▁▂▃▄▅▆▇█", and use a blank for missing values.
+This code was tested ok for Python 2.6 to 2.7 and 3.2 to 3.5.
+
+%package -n python3-sparklines
+Summary: Generate sparklines for numbers using Unicode characters only.
+Provides: python-sparklines
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-sparklines
+|ci| |pypi|
+This Python package implements Edward Tufte's concept of sparklines_, but
+limited to text only e.g. like this: ▃▁▄▁▅█▂▅ (this I likely not displayed
+correctly in every browser). You can find more information about sparklines
+`on Wikipedia`_. This code was mainly developed for running simple
+plausibility tests in sensor networks as shown in fig. 1 below:
+ Fig. 1: Example usecase for such "sparklines" on the command-line,
+ showing IoT sensor values (generating code not included here).
+Due to limitations of available Unicode characters this works best when all
+values are positive. And even then true sparklines that look more like lines
+and less like bars are a real challenge, because they would need multiple
+characters with a single horizontal line on different vertical positions. This
+would work only with a dedicated font, which is way beyond the scope of this
+tool and which would significantly complicate its usage. So we stick to these
+characters: "▁▂▃▄▅▆▇█", and use a blank for missing values.
+This code was tested ok for Python 2.6 to 2.7 and 3.2 to 3.5.
+
+%package help
+Summary: Development documents and examples for sparklines
+Provides: python3-sparklines-doc
+%description help
+|ci| |pypi|
+This Python package implements Edward Tufte's concept of sparklines_, but
+limited to text only e.g. like this: ▃▁▄▁▅█▂▅ (this I likely not displayed
+correctly in every browser). You can find more information about sparklines
+`on Wikipedia`_. This code was mainly developed for running simple
+plausibility tests in sensor networks as shown in fig. 1 below:
+ Fig. 1: Example usecase for such "sparklines" on the command-line,
+ showing IoT sensor values (generating code not included here).
+Due to limitations of available Unicode characters this works best when all
+values are positive. And even then true sparklines that look more like lines
+and less like bars are a real challenge, because they would need multiple
+characters with a single horizontal line on different vertical positions. This
+would work only with a dedicated font, which is way beyond the scope of this
+tool and which would significantly complicate its usage. So we stick to these
+characters: "▁▂▃▄▅▆▇█", and use a blank for missing values.
+This code was tested ok for Python 2.6 to 2.7 and 3.2 to 3.5.
+
+%prep
+%autosetup -n sparklines-0.4.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-sparklines -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.2-1
+- Package Spec generated