summaryrefslogtreecommitdiff
path: root/python-sphinx-changelog.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-sphinx-changelog.spec')
-rw-r--r--python-sphinx-changelog.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-sphinx-changelog.spec b/python-sphinx-changelog.spec
new file mode 100644
index 0000000..26e7f1b
--- /dev/null
+++ b/python-sphinx-changelog.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-sphinx-changelog
+Version: 1.3.0
+Release: 1
+Summary: A changelog renderer for sphinx.
+License: BSD 3-Clause
+URL: https://openastronomy.org
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8c/e0/7b98a5936c76d6d8f95b64907df0b56a8d5eeabf65034ea4befb01aa2248/sphinx_changelog-1.3.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-sphinx
+Requires: python3-towncrier
+Requires: python3-sphinx
+Requires: python3-sphinx-automodapi
+Requires: python3-pytest
+Requires: python3-pytest-cov
+
+%description
+This package provides a sphinx extension designed to facilitate rendering changelogs into your sphinx documentation.
+Currently this supports `towncrier <https://github.com/twisted/towncrier>`__ and inclusion of a ReST changelog file.
+For more details see the documentation: https://sphinx-changelog.readthedocs.io
+
+%package -n python3-sphinx-changelog
+Summary: A changelog renderer for sphinx.
+Provides: python-sphinx-changelog
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-sphinx-changelog
+This package provides a sphinx extension designed to facilitate rendering changelogs into your sphinx documentation.
+Currently this supports `towncrier <https://github.com/twisted/towncrier>`__ and inclusion of a ReST changelog file.
+For more details see the documentation: https://sphinx-changelog.readthedocs.io
+
+%package help
+Summary: Development documents and examples for sphinx-changelog
+Provides: python3-sphinx-changelog-doc
+%description help
+This package provides a sphinx extension designed to facilitate rendering changelogs into your sphinx documentation.
+Currently this supports `towncrier <https://github.com/twisted/towncrier>`__ and inclusion of a ReST changelog file.
+For more details see the documentation: https://sphinx-changelog.readthedocs.io
+
+%prep
+%autosetup -n sphinx-changelog-1.3.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-sphinx-changelog -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.0-1
+- Package Spec generated